Raspbian OS Bullseye touchphat errors

I have just come to install my touchphat on a brand new clean Raspbian OS bulleyes and I am getting errors when using he example code:

Traceback (most recent call last):
  File "/home/pi/Pimoroni/touchphat/examples/buttons.py", line 6, in <module>
    import touchphat
  File "/usr/lib/python3/dist-packages/touchphat/__init__.py", line 13, in <module>
    dh = cap1xxx.Cap1166(i2c_addr=0x2c)
  File "/usr/lib/python3/dist-packages/cap1xxx.py", line 253, in __init__
    self.i2c        = SMBus(i2c_bus)
FileNotFoundError: [Errno 2] No such file or directory

I am not sure what this error is telling me but I believe that it means the library can not be found, if I do import touchphat directly in the interpreter then I get the same error.

Any help would be greatly appreciated.


I think I’d give Buster a try instead of Bullseye.

Thanks yeah I know it works on buster but wanted to ask if there was a fix for this in bullseye.

Ah, OK. I don’t own a touch phat, just so you know. I do have a Piano Hat and Drum Hat though. They were setup a while ago, running Buster, might even be Jessie? Its an itty bitty beat box for my grand daughter to play with.

So far the only Pi I’m running Bullseye on is my Pi 400. It’s the only Pi I use as a desktop PC. Everything else is Buster and a few stragglers on Jessie. Most of my Pi’s run headless with hats etc on them. I only ever upgrade the OS on those if they need to be redone from scratch to fix an issue.

I’m having trouble with the Pianohat on Bullseye.
Depending on how I call it it either says I don’t have the midi module or pygame installed.
It looks like this:

This script requires the midi module
Install with: sudo pip install midi.

I tried sudo pip install midi. and that comes back with:
Looking in indexes: Simple index, piwheels - Simple index
ERROR: Could not find a version that satisfies the requirement midi
ERROR: No matching distribution found for midi

It’s the same for pygame