RetroPie doesn't show response for Joy Bonnet


#1

Hey guys

Bought an Adafruit joy bonnet from you last week and was testing it out yesterday with a Retropie image that I have. I followed all the installation steps on Adafruit JoyBonnet website and there were absolutely no problems. But when I log in to the EmulStation there is no response to pressing the buttons. So I connected a keyboard and manually went into the input configuration (in the menu) where it just says that it found no joystick present.

I am using a regular Pi Zero (NOT a Zero W) and I have checked the pin header soldering by connecting the Pi to a Scroll Phat and it works flawlessly. Is there any way to check if there is a problem with the JoyBonnet?

P.S. I don’t know much about electronics so I would appreciate a “for dummies” help!

Regards
Nayan


#2

I’m not quite sure where the JoyBonnet script is installed, but it might be worth trying to run it on its own and see what happens- if it crashes out with an error or otherwise, then we’ll know what’s up!

Oh looks like it should be in /boot/joyBonnet.py

Try dropping out of EmulationStation to the terminal and running:

sudo killall python
python /boot/joyBonnet.py

And see what, if any, errors it produces!


#3

Hi there

I tried running the joyBonnet.py as you said. First without using sudo it threw an error “illegal instruction”. But when i run the command:
sudo killall python
sudo python /boot/joyBonnet.py
absolutely nothing happens.

Then I tried to see if this meant that the script executed in the background by killing all python processes as you instructed. But it says there were no python processes running.

Could you suggest something else I can try to check if the Bonnet is okay?


#4

I’m having the exact same issue. Emulationstation does not detect the joy bonnet.
When I do sudo python /boot/joyBonnet.py I get “Illegal instruction”


#5

Go to /boot and check if you can see the joyBonnet.py file there (use ls). If its not there, then you may need to do the installation steps again. If its there, it means you also have a problem like me. Post your problem in the adafruit forums here.

Lets hope for a resolution. I am still waiting as well.


#6

joyBonnet.py is there.


#7

Entering this on the command line should fix it:

(Will need to reboot or manually re-run the joyBonnet.py script after this.)

There’s some issue in the Python evdev library present in older versions of RetroPie. Just updated the installer script on Github to do the above step automatically.


#8

Yes. It worked. Issue resolved. Thanks guys.