RPi 4, OSMC, power problem?

I got a RPi 4 2GB model to install OSMC and use as a media player for my bedroom TV.

Where the TV is on the wall meant that the standard power supply was not going to be long enough to reach the Pi. So I got myself a USB-C output power plug (max output power 18W, 3A@5V) and a USB-C to USB-C cable (rated for 5A).

When I boot the Pi with an OSMC (latest) imaged memory card, I just get the rainbow screen of ‘nope’.

I have another RPi 4 4GB model which is running OpenMediaVault, so I plugged in the new (OSMC) Pi with the power supply from the OMV Pi. Rainbow screen again.

Next, I tried re-imaging the memory card from OSMC to LibreElec, and the RPi 4 2GB runs just fine with the original power supply and cable that didn’t work above.

Next, I re-imaged back to OSMC again (I have 2 others in my house and like consistency), and once again it won’t boot past the rainbow screen.

So, why should LibreElec boot, and OSMC not boot? And if there is a reason, what can I do to actually get OSMC to boot?

Thanks!

OSMC as near as I can tell, is not yet supported on a Raspberry Pi 4B. I didn’t see any download for Pi 4B, just 3B and earlier models.

I did consider that, but I guess I assumed they just hadn’t added ‘4’ to the list.

Has anyone got OSMC running on a Pi4?

Mixed results, but I am guessing it is a no, which is surprising.

This one says yes, but is pretty vague about it. https://www.circuitspecialists.com/blog/how-to-setup-raspberry-pi-2-media-center/

This one says no. https://discourse.osmc.tv/t/does-osmc-work-on-raspberry-pi-4/81199/2