Servo 2040 not showing as storage device anymore

I purchased a Servo 2040 controller for an art installation that I’m showing next week, and it has has stopped working.

I had it up and running well, using MicroPython through Thonny to control multiple servos. I got to the point where I wanted to set the board to auto-run a program without my computer. I read online a recommendation of how to do that, and I believe what I tried was unplugging the board while holding one of the buttons.

From that point, my computer hasn’t been able to recognize the board when plugged in via USB in Thonny. I’ve tried to enter bootloader mode by pressing and holding boot, then tapping reset, but the board does not show up as a mass storage device. I’ve replaced my USB cable with a data/power one, and that hasn’t helped. It seems like no combination of buttons I try will make my computer recognize the board.

I’ve looked through a bunch of forum posts with no avail, any suggestions would be very appreciated. Also, as context, I’m a total newb at this stuff, so highly likely I’m making an easy error.

There are two ways to get into bootloader mode.
Press and hold down the Boot button.
Plug in the USB cable, then release the Boot button.

If its already plugged in and powered up.
Press and hold down the Boot button.
Then press and release the Reset button.
Then release the Boot button.

To have it run a file on bootup save it on the Pico as

I’ve tried both of these methods and neither works for me.

Sounds like it has failed for some reason? If you can’t get it into Boot mode there is no way to re flash it. Have you removed / unplugged everything from the Servo 2040 headers?

Yep, removed everything from the headers.

It just seems completely dead, that’s what I feared with regards to failure, I actually ordered a replacement, but am a little concerned it won’t arrive in time for my gallery showcase. Crossing my fingers, I appreciate the suggestions.

Ok, I was thinking something attached to the headers might have failed, causing a ground / short somewhere? It’s hard to just give up, been there done that. Also sucks when you don’t have a spare.

Have you got any other Pico’s plugged into that same PC? I ask because my Circuit Python programed Pico causes other Pico’s to show up as an unknown device, device descriptor has failed. It I unplug “it”, I can then see and flash that other Pico.

Nope, no other Pico’s, and the computer doesn’t show any signs of recognizing it at all (sadface).

Do you have a voltmeter? If you do I’d measure the +5V and 3.3V.
I’m thinking the 3.3v regulator has failed? Did it come into contact with any metal / conductive surfaces?

Have you tried a different USB port on your computer, and/or fully power cycling it? I’ve occasionally got the USB stack so badly screwed up that only powering off and back on resurrected the damn thing…

Attention if you are on a laptop with Win10 and no power supply the usb port a limited in power courant A