Skywriter Hat issue = An invalid GestiIC Library was stored, or the last update failed


#1

My skywriter hat worked until there was some Hill something update notice.

The firmware update did not seem to go well.

Focal point of error: An invalid GestiIC Library was stored, or the last update failed

The rest…any ideas?

My error:
ython synth.py
Got firmware info
LL0:100.14;p:H
Exception in thread Thread-1:
Traceback (most recent call last):
File “/usr/lib/python2.7/threading.py”, line 810, in __bootstrap_inner
self.run()
File “/usr/local/lib/python2.7/dist-packages/skywriter.py”, line 107, in run
if self.todo() == False:
File “/usr/local/lib/python2.7/dist-packages/skywriter.py”, line 336, in _do_poll
handle_firmware_info(data)
File “/usr/local/lib/python2.7/dist-packages/skywriter.py”, line 296, in handle_firmware_info
raise Exception(“An invalid GestiIC Library was stored, or the last update failed”)
Exception: An invalid GestiIC Library was stored, or the last update failed

Populating temp PD file: /tmp/tmp3SmxXi
Started PD with PID: 1525
File: /tmp/tmp3SmxXi
Attempting to connect to PD
Connected to PD


Skywriter XL not working
#2

I’m not clear on what created your issue, a Pi software update or something else? Please, give us as much details as you can about the steps that lead to a working system leading where you are now.


#3

I attached sky writer hat to pi zero w and installed software.
Test.py or synth.py ran and returned position data along with the north,south or east west .
Cannot remember which example…but it worked.
I shutdown the pi at command line and went to sleep.

Next day, after boot I ran synth.py and got this sort of error:

f I move my hand over or tap the sensor nothing happens, except the same stream of firmware info.

Got firmware info
1.1.18;p:Hills
Got firmware info
1.1.18;p:Hills
Got firmware info
1.1.18;p:Hills

So I followed the instruction to solve this from the thread and:

git clone https://github.com/pimoroni/skywriter-hat cd firmware sudo python ./update.py

I do not have exact errors, but it it went through blocks 1 to 108 and then would say update failed and then try to update again.

So now it gives the error I posted first.


#4

Wow…is that it? I followed directions from another blog post and now I am out of luck? So is it now just a waste of my money and a paperweight?


#5

Can someone give me options? Or should I just consider the Skywriter and Pimoroni a waste of time as well as money?


#6

I suspect that @gadgetoid may be able to help here. If we can’t get the problem solved, then of course you’d be welcome to return the HAT to us for replacement.


#7

Before chalking it up as a fail, try:

sudo python3 ./update.py

Sorry it took so long to get a reply. It’s always worth pinging support, or sending a DM on the forums if your reply goes unanswered. The forums are tricky to keep on top of.


#8

I will try that and see what happens. Thank you.


#9

I finally was able to get to try this and it fails and loops. Every line item gives a BLOCK OK.
At end of each sequence of successful BLOCK update the result is as follows.:
Finishing update…
Finishing update failed!
Retrying…
b’LL0:100.14;p:HillstarV01 ;;i:B;f:25000;s:Beta2r1059:MO;c:MKI;t:2013/11/13 11:48:\x00\x00\x00\x00U\xaa\x90e \x80\x0f\x00\x00\x00\x00\xfa\xfc\x00\x00’
Starting loader update…
Loader update failed!
Retrying…


#10

How are you connecting the Skywriter, and onto what type of Pis? Additional question: what type of power supply are you using?


#11

Pins are soldered to pi as delineated on the pin out diagram…resoldered(or heated to re-melt) to ensure good connection.
Then the pins on ends of these short jumper wires are pushed into the correct sockets on the hat.

Pi zero w is used

Power supply is a USB supply made specifically for the pi.

Keep in mind, the hat worked perfectly. Then after a command line shutdown of the pi…and a reboot the next day, the issue illustrated at first post above began to happen.


#12

There must be a connection issue. Can you please post a picture?

Also, how many ground lines have you used? Try to link additionals.