Speaker Phat worked and then stopped working


#1

Im using a new raspberry pi w

I installed the speaker phat and it worked for like 2 minutes… when I ran the test file it worked but started to crash during the VU meter test part.

Then the LEDs stopped working… I thought it was some software issue or soldering issue so I started over with a fresh version and a fresh sd card…

Initially it didn’t work but all of the sudden worked! I played some Tetris and I noticed my LEDs were stuck in the some position and they wouldn’t turn off…


I rebooted and my LEDs won’t work but my sound will… again the LEDs aren’t working

I didn’t do anything but used the speaker for a few minutes … in the second case I used it to play some Tetris


#2

A good picture of your soldering might help. It looks a little rough in the video. I think it might be something to clean up fix up a bit to rule it out as an issue.


#3

I read somewhere that it might be the solder… but it looks good to me… what’s your opinion?


#4

I’ve seen worse. Not too bad really. Check the pad right under the white 96 and make sure there isn’t a solder bridge between it and the one next to it. The one on the other side of the whit line. Might just be flux, hard to tell. You don’t want any pad shorted to another one with solder.


#5

wow that was weird… the phat beat worked for a few and then stopped working so i honestly didnt think it was the soldering… i redid the soldering and voila it’s working!!

thanks again


#6

I’m a retired electronic technician, soldering is second nature to me. It’s tricky telling somebody that hasn’t done it very often , or their first time, that they didn’t do a good job. You don’t want to insult them etc. Most take the criticism OK, some don’t? It’s also hard to tell how bad it is just from a picture. Cold solder joints are hard to spot in a picture. I am so glad you redid it and fixed it. You likely had a cold solder joint in there somewhere. They look OK but have a poor contact. High resistance or even an open circuit.
https://learn.pimoroni.com/tutorial/sandyj/the-ultimate-guide-to-soldering


#7

So it stopped working again!!

This time the LEDs work but the sound doesn’t… argh!!!

I redid the soldering hoping it would fix it but it didn’t so I’m out of ideas

Also even when the sound worked I could never get the airplay to work


#8

Did your Pi Zero come with the header pre soldered? If no, have a look see at that.


#9

Tested it in two raspberry py zeros and it’s doing the same … I slso redid the soldering…


#10

I don’t know what your issue is? Best guess is excessive heat during soldering damaged something. Just a guess though?


#11

Here is another video of it

Is there any way to test this using a voltage meter? I placed my voltage meter on the Teo silver cables that connect to the speaker but I didn’t see anything

How high would the voltage be while it should be playing songs


#12

It would be a AC voltage, probably to low to measure with a meter. Try the lowest AC Volts range.


#13

cant get any voltage…


#14

I think you’d need an oscilloscope to see that.


#15

So I soldered a tiny speaker onto my speaker phat board and it still does’t work… I think the board is a dud…

I honestly thought I was saving time by buying this instead of a amplifier board and a speaker… but it doesn’t seem to be the case…

I spend hours trying to figure out what’s wrong and it works whenever it feeel like…

I’m buying solderless pins… I honestly don’t think that it was my soldering that wasn’t working… I soldered many other items before and I never had any issues…

Do you know how I can get a refund or a replacement on this?


#16

Go to the main page, then click the contact us link at the bottom. I’d put a link to this thread in the e-mail you send.


#17

To be honest, your soldering job wasn’t the best. I have seen worse though. Not meaning to offend you or disrespect you, just an observation from somebody that has been doing it for many many years.
Have a look at this, https://learn.pimoroni.com/tutorial/sandyj/the-ultimate-guide-to-soldering It may save you some aggravation and frustration in the future.


#18

i agree that it could have been the soldering when it was not working… however, it worked and then stopped working 5 minutes later… i didnt make any changes during this…

i’m going to test another board with solderless pins and i’m going to test this again…my theory basing my experience and the dozen of post i been seeing online is that these burn up as there is no volume controls/… seems like the more you use them the more they burn up.

i will post videos about it later on


#19

Volume I believe is handled by the OS, Raspbian. It’s a digital signal so you can’t just stick a potentiometer in there. The pHat Beat, which is what I have, has buttons to adjust the volume, but that’s just a software volume control. Not making excuses, just an observation. I do get what your saying. It hasn’t been an issue for me and I don’t know what the solution is. My Pirate Radio install is only loud the first time I start it after installing it. After that it remembers where I left the volume set at when I turn it of.