Still No Signal on Picade

Please help!! I’m helping my teenage daughter set up her Picade with Pi4. She is super excited, but getting very frustrated!! Build is complete, Retropie is on sd card, but we are still getting ‘No Signal’ message after we turn the Picade on. Already tried removing # from hdmi_force_hotplug=1. Also made sure cords were installed correctly. Any other suggestions? Thanks!

If you have a spare SD card try using just regular Pi OS with desktop. It should make trouble shooting easier. You don’t need to install any of the Picade software to get the display working so skip that for now. Take the Picade Hat off if you want.
Make sure the display is plugged into HDMI 0. And if you have a spare power supply power the display with that. Power the display up first, then the Pi.

Thank you for your help!! After much time, frustration, and experimentation, it ended up being a faulty hdmi adapter that came with the Picade. We bought a new cord that was delivered today and things booted up right away!

Bummer, take the good with the bad though, now its working. You can enjoy some games now.

1 Like