Unicorn HAT - latest Raspbian [ SOLVED ]


#1

Hi,

Was just trying to get an old UH project running on the latest Raspbian and notice the UH was outputting garbage. So I tried to run a few of the examples, but to the same result.

I work over remote desktop, but I plugged in an HDMI cable, connected to the Pi again and ran everything fine.

Is this the analogue audio causing problems in the background when I don’t have an HDMI cable connected?

Is there an easy fix?

Cheers,


#2

Ah looks like this may be it:

http://forums.pimoroni.com/t/new-unicorn-hat-not-working/2317/20?u=major_tomm


#3

Yes, some recent changes in Raspbian have caused a bit of a headache. Things should be back in control using the current ‘one-line-installer’:

curl -sS get.pimoroni.com/unicornhat | bash

… at least I expect it to be so.


#4

Ah cool cheers. Couldn’t remember when I last grabbed the repo. I’ve made a note to myself in the code to remind me next time I forget :)


#5

Added the SOLVED tag for other people who might stumble across this. Glad you’re back up and running!


#6

Cheers, doing a talk on Arduino and Pi at my Maker Space today, so couldn’t be without some shiny stuff!