Unicorn Hat / RPi2 / Arch Linux Problems


#1

I have some problems getting the Unicorn Hat to work on Arch Linux. I own 2 RPi2 and with the hint in Unicorn hat with Arch Linux? I succeeded in getting it to work on one of both. But on the other Pi the python example scripts fails at the line:

import unicornhat as unicorn

There’s no error message or something else, it’s just using up one core of the RPi2 but doing nothing. It’s also not killable by Ctrl+C, I have to end it by killing the process. I’ve no idea what’s the difference between the two installations :(

Maybe someone experienced the same and can give me a little hint?! I think that’s just a stupid / simple thing but have no idea what it could be…


Unicorn Hat / Arch Linux / GCC 5
#2

OK, just solved the problem by myself. A reinstallation of the python packages, a new “git clone” of the repo and another try of “python setup.py install” and voilà, now everything is working. I tried all of these steps earlier and don’t really know where the problem was, but since it’s working now, I’ll not complain ;)