Accessing files on enviro indoor

so stupid question time… i’m new to Pico and bought a enviro indoor to experiment with.

I’ve followed Upgrade Firmware and installed enviro-v0.0.2.uf2

I’ve then followed the Getting Started Guide and set it to store recordings locally.

In the related documentation it refers to items like and viewing the logs… but I cannot see how or where to access the files on the pico? I’m connected the board via USB to a Ubuntu 18.04 PC but no drive is appearing to browse files.

A Pico running Micro Python won’t show up as a USB device. Circuit Python does that but Micro Python doesn’t. In Thonny there is a View > Files option that may get you what your after.

Thanks for the advice. Think I’m struggling to connect using Thonny. I’ve downloaded & installed latest Thonny from I’ve set MicroPython (Raspberry Pi Pico) as the interpreter.

The enviro indoor is connected to USB cable. With port set to “Try to detect port automatically” nothing happens. I have two other options on my computer:

  1. ttyS0 (/dev/ttyS0)
  2. n/a (/dev/ttyS4)

When I select either and press OK, a few secs later in the shell box it reports

Device is busy or does not respond. Your options:

  - wait until it completes current work;
  - use Ctrl+C to interrupt current work;
  - reset the device and try again;
  - check connection properties;
  - make sure the device has suitable MicroPython / CircuitPython / firmware;
  - make sure the device is not in bootloader mode.

When connected via USB the Activity (White) LED is on permanently on the enviro board which I assume is the correct state

Widows or Mac PC? Auto Detect hasn’t worked for me in a while. I set it manually, and if that Pico is running a, I click stop to get access.

Linux/Ubuntu 18.04.5 PC.

Last night, I uploaded the Raspberry PI Pico W UF2 and on restart Thonny immediately detected the Pico (on automatic settings - I noted it created a new port, not shown above), there was a MicroPython shell and I could see the files on the Pico (yay!)

I uploaded the latest 1.19.7 Pimoroni Eniro UF2 and on restart, the activity LED is on but Thonny doesn’t show a connection and there is no file list from the device.

This implies Thonny 4.0.0 does not work with the Pimoroni Enviro 1.19.7 UF2 image?

Kind of looks that way? I haven’t yet installed or tried Thonny 4.0.0. Haven’t been able to find my round 2it.