Any picture/video I take with the camera module V2 is just a grey screen

Hi Everyone,

I purchased a V2 Camera Module from Pimoroni and installed it today.

I ran apt-get update && upgrade, enabled the camera in raspi-config and then restarted. I then tried to take a picture and a video using raspistill and raspivid and everything seems like it works. The jpg and h264 files are created but when I open them p they are just a grey screen with some lines on them.

It looks like this

I ran the command vcgencmd get_camera and the output is "Returned Supported=1 Detected =1)

Anyone any ideas?


Maybe this will help figure out what’s going wrong.

I have to ask the obvious, you pulled the lens protector tab thingy of right?

Thanks for the reply alphanumeric!

I did pull the protector thing off yes, although it wouldn’t be the first time I thought something was broken because of a reason like that haha.

I’ve read through that link you shared a couple of times but unfortunately nothing helped.

I’ve had a response from Pimoroni to say to return it to them and if they find it to be faulty then I will get a replacement. I’d rather not go down that route since I already have the camera and i’m wanting to crack on with my project but if that’s what needs to be done then so be it!

Thanks for your help.

Ok, wasn’t sure if you had seen that link and done what was listed.
I would at the very least reseat the cable at both ends. And also carefully reseat the SUN connector on the camera. Thats what the Pi Foundation calls it. On the lens side right next to the lens is a connector that connects the lens to the main board. There will be a small ribbon cable between it and the lens. You can lift that with your finger nail then reseat it back in.
I had one camera start showing some vertical grey streaks in its image. This was after many years of use and being knocked around some. A friend gave me his dead camera and I swapped out the lens part. I just undid the SUN connector and swapped them. Mine was then fixed. His main board must have died. Both were version 1’s that had seen lots of use.

Do you see an image on your monitor at any time, like in preview mode? I have several cameras here, V1’s and V2’s. Mine are all running Motion Eye though. I haven’t used one in Raspbian in a long time. I do remeber being able to see what the camera was seeing on my monitor in Raspbian though.