Blank screen W10 IoT Core


#1

So I have made some other mistake or maybe it’s just my pi. Luckily no more horrible trouble with that unicorn pat (managed to make that to work brilliantly! This time it’s to do with another operating system, Windows 10. So I follow the instructions and manage to get the system working, kind of. I turn it on and it comes up with the windows logo and spinning loading circle. Then that goes away and reveals a blank screen, just some black pixels (they are turned on but don’t show anything but black) sorry for the bad camera quality. And Thanks everyone who helps. Techboatman


#2

Can’t work out how to add images


#3

I just drag and drop into the box. You should then see a preview of the image over on the right.


#4

The last couple of times I tried 10 IoT it always failed on the first boot. It just stalled. I just power cycle it and then it boots up OK. Been a long time since I used 10 IoT though. Have you ever used it before?


#5

https://lh3.googleusercontent.com/ujjf07ZPXT00oIxePMiSwfZJgZacNDY5ttcCA8gfyio0Rp-uGNIJZWOtHcw5EFOhGWRDqSD876jZtpeGDo9m6oJE2BVarwrIO5vYIT0O9EeGdqJ6tWKmP5see27mRuHWunCk-AD1FIRcBzZF3IuVAzy_zLTEHKRNwzSRXpnvpCT87jAdm4avK5VOC8Nkq-Qk2lIj-SVDMKZrSK82UBUrJwN2rmjILGuRkdqXjHKlzy7YiExiQ-BCRhOvotDOSzceFYizSkvjS-e70_l_keJIBYkwDJNzYFj-gyBygVjgWMieUgAP4_vxUP1re_pU9yMG_n2cEE2Yff_SN6-YfRo-_D5vHFSZri68bXcB6oZoNQuxAbs-WTnh2rSDlRQK9Py85ymOSIQ9mk1nnBGErwwyzTTNaiLsLGV-uw5gCwCP4LULE7qt9SY4CE4zYbXKc9nClAlcv-nhUvXpz68a3wgw-1PI_7eTD4vY2QQL6TP3ozOSO8tThfG4FUzlLDxCkoxoJuGsupb9ednRXr7MrbC4HgViGBAAO9zOHcoKbjSTN9wN_2N3yi1OIsCIAuGfOqLo6WVCFRAXEwD-jx4KCQR6m67rab_9egWKSwkjIiQ=w821-h1094-no


#6

Didn’t Work
I have tried a number of times to install it but never really had the time.
Turning it on and off does not work for me don’t know why.


#7

https://photos.google.com/u/2/photo/AF1QipMZpaF21NxwwdH1QH5P0axXZJp74sAwej2F1Qoe


#8

yes!!


#9

Oh and I forgot to say that one thing I did read is that only 8 and 16GB SD cards work and I have a 32GB SD card in. What makes me not believe that is that you can’t really have an SD card to big for a software, it works fine on the raspberry pi as that’s the SD I used Raspbian on (please note the SD card has been erased now). I do have a 16GB one and an 8GB one somewhere but I wouldn’t really want to erase my 16 Gig one. So I can’t test those and I’m sure that’s not the reason, also thanks @alphanumeric for all the help so far!


#10

That looks to be where it locked up for me. Have you ever used 10 IoT before? I ask because its not at all like any other version of Windows 10. There is no start menu, no Apps, other than what you install. And that’s not all that easy, there is no Store. It’s just a very basic shell, unless its changed since I last used it. What is it you want to do and or use it for?
There is an official Microsoft forum for it by the way. https://social.msdn.microsoft.com/Forums/en-US/home?forum=WindowsIoT
About all you’ll see is this once its booted up.


#11

You see I haven’t used Windows 10 IoT Core but it doesn’t seem that challenging, and even if it isn’t exactly Windows 10 it’s still a formula of it. I do get that you make stuff happen by uploading it from the computer (maybe I’m wrong). So you think that it probably is the SD. If that’s the case I’ll have to do some searching! Thank You!


#12

Ok, Just wanted to know, if you knew what you were in for. Some think its a full Windows 10 and get very disappointed when they see what it actually is. I do believe all the magic is done with Visual Studio. The making and uploading of your Apps etc.
If you have , or can get, a recommended SD Card I would. Should have asked this long ago but what Model Pi are you trying to run it on? And newest IoT image available?


#13

Don’t know what IoT version but am running on raspberry pi 2 model b


#14

I’m just setting one up myself, following this, https://developer.microsoft.com/en-us/windows/iot/Downloads
It shows raspberry Pi 2 & 3 for Device type,so the 2B is supported.
OS Build shows IoT Core (16299)
Drive is showing as 7Gb Generic Mass-Storage USB Device, its an 8 Gb Sandisk Ultra. The 7Gb may be because it had Raspbian on it and one partition was a Linux partition. I’m just going to plug it in and boot up. I’ll post back how it goes in a bit.


#15

Just booted up,
First screen is the circling dots Windows Logo screen.
Next screen is a blue Welcome to Windows 10 IoT Core, please wait while we get things ready.
Then briefly flashed the main screen with the picture of the Pi on it and went to the WIFI setup screen.
That screen timed out while I was typing this post, went into settings and setup my WIFI. Now I’m back on the main screen. Looks like it setup Ok this time around. Pi 3B here, I don’t own a 2B.


#16

The IoT dashboard found it on my network OK. Its listed as
minwinpc, Raspberry Pi 3, 10.0.16229.15 for OS and shows its IP address.


#17

It’s improved since my last test run, web browser, command line, tutorials.

Still have no idea why your install fails though? I’d only connect what you absolutely have to, to the USB ports. If your using a WIFI dongle unplug and see if it fully boots up. All I have connected is a Logitech K400 wireless keyboard.


#18

OK so I tried reinstalling Raspbian. Guess what it starts up and the screen turns black. Typing in F2 -F5 or maybe 6 does bring up the command line but typing in startx brings up black screen. I have tried many things the most successful yet being going on to raspiconfig and then changing the setting so that it auto boots the GUI instead of startx. That brings up something asking for the password and then I type it in and just shows the background picture and nothing else.


#19

There is an option to boot to command line and auto log in. You need to check the box for “Login as user Pi”.
If you run sudo raspi-config from the command line you will get the old GUI and can change your log on settings.
It sounds like your monitor might be the issue. Have you got another monitor or a TV to try instead. Or a different HDMI cable?


#20

Nope. I will try that.