Can't get Mote Host to work on macOS


#1

My Mote host (with one light strip connected to it) is currently plugged into my Mac and running this:
import mote my_mote = mote.Mote()

results in this:

Traceback (most recent call last): File "/~/Desktop/mote_control.py", line 3, in <module> my_mote = mote.Mote() File "/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages/mote/__init__.py", line 38, in __init__ raise IOError("Unable to find Mote device") OSError: Unable to find Mote device

Not sure where to go from here. I’m using Python 3.6.1 and got mote and pyserial from pip just a moment ago.
What do I do to get this working?


#2

I’m really not sure whether it would work under Python 3.6, we’d have to check.

… That said, have you tried it on a Pi, or trying to run the Mac demo located in our repo to ensure the hardware function normally otherwise?


#3

Make sure you use the right port on the host, and that your Mac can see it.

I believe you can look for USB devices in Terminal with: ls /dev/tty.USB* but my Apple-fu is a little rusty.


#4

Just tried the Mac demo, but it fails with the same “unable to find device” message.
I’ve been trying to get it to work on a Pi, but I haven’t been able to compile Python 3.6 yet, so I’ll report back once that’s done.


#5

Alright, got it to work on the Pi. It seems that it’s just the Mac version that doesn’t work.


#6

What model of Mac, what version of OSX?


#7

This is on a Hackintosh mimicking a Late 2015 Retina iMac running macOS Sierra 10.12.4.


#8

Eeek, that may be tricky to re-create :D

I’m going to guess it’s something to do with the Python serial library and Sierra, but that’s a guess at best. I’ve got access to a Mac to test with, but no Mote at the moment. I’ve got looking into this on my TODO list when I have the bits to hand, though.