Getting Mote to work under Bookworm

I’m trying to get a new Mote hat and sticks to work on a Pi Zero 2 using a fresh install of Bookworm Lite (32 bit) and it’s not working.

Install worked, at least after I did the removal of the external management of Python ( sudo rm -rf /usr/lib/python3.11/EXTERNALLY-MANAGED) but none of the demo examples can see the mote.

Doing some research I see there’s comments about pyserial, which I have installed already. It’s version 3.5 though, which some comments say has a bug?

Where should I go from here to get it up and running?

Traceback (most recent call last):
  File "/home/darren/Pimoroni/mote/examples/", line 9, in <module>
    mote = Mote()
  File "/usr/lib/python3/dist-packages/mote/", line 42, in __init__
    raise IOError("Unable to find Mote device")
OSError: Unable to find Mote device```

Did some more testing here, and under Buster (exact same hardware, just reimaged the SD card to a fresh image) and all worked fine.

So it’s specifically Bookworm that’s breaking things here.

Can we expect anything here given Mote is obsolete (albeit still on final sale on the site), and is this something that’s going to get problematic for other install scripts in Python 3?