EnviroGrow: solid red LED and doesn't boot when using JST-PH power connector

I raised an issue about this on GitHub at EnviroGrow: solid red LED when using JST-PH power connector · Issue #24 · pimoroni/enviro · GitHub - seen by helgibbons but there has been no suggested resolution. I suspect the board must be faulty.
Is there anything else I should try before returning the board for replacement?

Sorry for the slow reply - we’re all kind of snowed under with the birthday sale at the moment!

If you drop a message to support (with the order number and a link to this post or the Github issue) they should be able to sort you out with a replacement: Contact Us for Raspberry Pi Technical Support - Pimoroni

Will be interesting to poke at this one if you’re able to send it back, very odd that you’re only getting the red light whilst powered via the battery connector!

Hi @hel,

I’ve got a similar problem with my Pico Weather. When using the supplied 2xAAA battery pack, the red warming LED comes on. If I push the poke button, the white LED flashes very briefly, the red LED turns off & then nothing happens - even if I push the poke button again. The only way I get some form of reaction is by either disconnecting power, or by pressing the reset button.

Secondly, the board is also acting erratically when connected to my PC via USB. At times, the board isn’t detected by Thonny (my Thonny settings are correct) - when this happens the white light on the board is on. At other times the board randomly just looses connection. The board either appears to get stuck while running main.py, or I get the “unable to connect to COM3” error message. Hitting the "Stop/Restart button in Thonny doesn’t help either. I have to physically disconnect the board before trying again.

I’ve tried running the firmware which came with the board (not sure what version that was - which is why I think the version should be commented in the code somewhere), 0.0.2 and the prelease version of 0.0.3.

I’m at a loss as what to do / try next. Any suggestions?

Out of interest, what is the minimum power requirements for the board to run? The batteries which were supplied with the battery pack are measuring 0.98v (when in the battery casing). A new set of AAAs (after leaving them attached to the board for 1 day while at work) are measuring 1.02v (also when placed into the battery casing). I’m wondering if the red LED is being activated due to not having enough power. I’m not sure why the batteries are being drained so quickly. This however doesn’t explain the odd behaviour when connected via USB.


@Captain_Blackbeard One thing I think I’d do is replace the 2 x AAA battery pack with a 3 x AAA or 3 x AA. My Tufty came with a 3 x AAA, that gives me all kinds of battery endurance. It also bumps the voltage up to 4.5V versus 3V.

I’ve had issues in Thonny if I have my Pico RGB Keypad plugged in, that is running Circuit Python. It messes with any Pico running Micro python. Especially when trying to connect in Boot mode. I get unknown device until I unplug the RGB Keypad?

Seeing the same with my new enviro indoor…

Red warning LED while on battery; erratic when connected via USB. It worked some days ago but never managed to get more than one reading per boot and now see the dreaded “USB device not recognised”.

Little info (e.g. Getting Started with Enviro (Pico W Aboard)) available to help so not sure where to go from here and would appreciate any ideas.


I agree. I think Pimoroni (@hel) should have shipped the Enviro Weather kits with a 3 battery pack instead of 2 x AAA.

I’m using the new voltage reading in the version 0.0.3 beta scripts to monitor the battery performance. The pico’s reading frequency is as suggested by Pimoroni (reading every 15min, upload after 10 readings), where they claim that the battery “should last for months”. Will see how this goes…

Minimum voltage for a Pico W to run is 1.8V - this assumes no other connected hardware though, so minimum working voltage for an Enviro is likely to be higher. It shouldn’t be exhausting the battery pack over the course of a day though 🤔

We’re still making a ton of bug fixes to the Enviro firmware, so definitely worth updating to the newest version of the firmware (More fixes happened this morning so I suspect there may be another release along shortly - might be worth hanging on for that).

Hopefully the battery lasts longer now that rain wakeups are implemented a bit more sensibly - I know my Weather board was churning through the battery when the rain sensor was waking it up and causing it to connect to wi-fi more often. I think there were also a couple of bugs circulating where an Enviro could crash whilst awake and so not go back to sleep.

@Captain_Blackbeard The sensors on Weather shouldn’t need much power (unlike the pumps on Grow and the particulate sensor on Urban) which is why we went for a smaller battery pack for this one, but if you find yourself needing a bigger battery pack I’m sure we can sort that for you :)

Thanks @hel for the added details. There is something definitely “odd” with my Weather board’s performance. I sent an email to Support last night with some details. I have upgraded the firmware to 0.0.8 and it still experiences issues.

While under the previous firmware version (0.0.3 I think), I had another example of the board draining the battery within a few hours (went from 3v to 1v). I think the board gets stuck at some point and doesn’t enter its sleep mode - hence it drains the battery. I have not experienced similar issues with my Grow board - hence I suspect that there is something wrong with the weather board.

When testing by the board last night (using 0.0.8), via USB and Thonny, I’d say that I had a 50% success rate of launching main.py where it ran all the way through to the end of the script. There wasn’t any noticeable pattern to when or where the board froze - it is very odd.

I’ll wait for Support to reply to my email - perhaps they can suggest some potential troubleshooting ideas.

My replacement EnviroGrow (with sensors but no pumps) is occasionally exhibiting the “solid red LED and doesn’t boot when using JST-PH power connector” issue. But I accidentally discovered that I can get out of that and get normal operation by a long press (>3 seconds?) of the ‘poke’ button. Maybe there was nothing wrong with my first board after all?

How long is the ‘poke’ button meant to be held? Short-press doesn’t ever seem to do anything. Is a ‘long-press’ intended to do something different? Is this by design, an undocumented feature or a bug?

@ExperiMentor Interesting - any indication in log.txt what it’s trying to tell you with the red light?

The poke button probably will need a more solid press if waking the board from battery as it’s starting up MicroPython from a powered off state. There’s a short delay while it does that, so it can miss quick button presses.

@Captain_Blackbeard Support should be able to sort you out with a replacement board if necessary. Feels like this could be alpha software weirdness though - is there anything in log.txt to suggest what it might be doing to use so much battery (or that might show if/why it’s getting stuck awake?)

I’ve also seen random hard crashes with the newer images when running main.py through Thonny - it’s probably worth opening a Github issue about this one? Haven’t had much chance to experiment with the new releases yet - catching up with a bulging inbox after a weeks holiday!

EDIT: Have opened an issue about crashes in Thonny -v0.0.8 hard crashes in Thonny · Issue #78 · pimoroni/enviro · GitHub

No there isn’t. When it’s SOLID red LED, it occurs immediately after applying power via JST and the board does not power up and nothing is written to log.txt. After long-pressing the poke button (and it needs a really long press), the red LED goes out as the button is released and white flickers then flashes as for a normal power-up and log.txt has usual content.

Other times, I get flashing red LED after attempted data upload to adafruit. Log.txt usually indicates data flow overload (trying to upload too many data points within a minute to free adafruit account). The non-uploaded files remain and red LED flashing continues until next upload attempt (depending on how many files are still waiting …), then recovers gracefully. I see the new firmware no longer waits 30 seconds to retry - it just fails gracefully until next time.

Hi @ExperiMentor. I think there are a number of bugs in firmware 0.0.8, which I’m hoping will be resolved when the next version is released. For now, I’ve unplugged all my Enviro boards as they are all flashing red - due to the code not having an Adafruit IO timeout allowance for submitting data (x number of data points per minute)

The current behaviour seems OK to me. It’s for the user to not send too much data if they don’t pay for a non-free Adafruit IO account. On EnviroGrow, there are now 8 datapoints generated at each measurement timepoint, so you can only send data from 3 timepoints at a time (as 4 x 8 = 32, so it fails on the 4th set). I made a modification to omit one datapoint (eg, do you need Lux?) and send 4 x 7 = 28 datapoints at a time.
I only get the red flashing error LED when the WiFi connection has failed (the plants are borderline too far from my router). A small iimprovement that could be made would be to retry connecting and sending data at the next measurement timepoint if there was an error at last attempt, rather than waiting until there are X files available. That would avoid the red flashing persisting for so long.