HyperPixel - 3.5 no touch


#1

Hi
I just got my Hyperpixel today and ran the software following these instructions…


Disappointed that the screen needs so much effort to get working on my Raspberry Pi 3B+ and still no luck…The Mouse works but the Touch does not work at all.

errors:
If I run
system service hyper pixel-init status - Status is running
system service hyper pixel-touch status - Failed

LCD Touch Screen Driver Daemon
em/hyperpixel-touch.service; enabled; vendor preset: enabled)
nce Tue 2018-06-19 17:24:05 BST; 5min ago
ixel-touch (code=exited, status=0/SUCCESS)
ILURE)

ixel-touch.service: Unit entered failed state.
ixel-touch.service: Failed with result ‘exit-code’.
ixel-touch.service: Service hold-off time over, scheduling restart.
d Hyperpixel LCD Touch Screen Driver Daemon.
ixel-touch.service: Start request repeated too quickly.
to start Hyperpixel LCD Touch Screen Driver Daemon.
ixel-touch.service: Unit entered failed state.
ixel-touch.service: Failed with result ‘exit-code’.
~

Please help

regards
J


#2

Did you just run the one line installer, curl https://get.pimoroni.com/hyperpixel | bash or do the long manual install? Are you running the latest Raspbian Stretch?


#3

Hi

Currently running Raspian Stretch.
I ran sudo apt-get update and upgrade to get to that version since the USB SD Card was an older version straight out of the box.

I ran a full install and followed up with manual installation for the parts that were not installed, then ran the short one gain (curl https://get.pimoroni.com/hyperpixel | bash) when touch still didn’t work.

The parts I checked and found missing:

a) If you’re on Raspbian Stretch (Debian 9.3), that config file doesn’t exist. Instead, append consoleblank=0 to the boot command in /boot/cmdline.txt and reboot.

b) LCD Display

Make sure you have the OpenGL video driver disabled. You must use the “Legacy (Non GL)” driver which you can select in the “Advanced Options” section of raspi-config.

c)Touch Screen

We need to ensure the evdev module is installed for Python. The easiest is to grab our pre-compiled deb file:

sudo dpkg -i ./dependencies/python-evdev_0.6.4-1_armhf.deb
alternatively, you can install it from source like so:

sudo apt-get install python-dev
sudo pip install evdev

d) Make sure you add uinput to /etc/modules.

e) Make sure the relevant files are executable:

sudo chmod +x /usr/bin/hyperpixel-init
sudo chmod +x /usr/bin/hyperpixel-touch
And ensure the services run on startup:

sudo systemctl enable hyperpixel-init
sudo systemctl enable hyperpixel-touch

The rest of the manual configuration already had the files in the correct place.

regards
J


#4

So Stretch may be the issue? I should mention I don’t own a hyper pixel. Not yet anyway.


#5

Hi
thanks for trying to help, however I was hoping that tech support should have answered this because this is where I was told to put my questions.

I am a new customer so I hope they will get back to me very soon, since I am needing to work out a solution for projects I am preparing to implement in abroad.

thanks
regards
J


#6

Do you have the hyperpixel-overlay.dtbo file in /boot/overlays and enabled in /boot/config.txt?

What happens if you: ls /dev/i2c-*

And also (check the touch log) cat /var/log/hyperpixel-touch.log


#7

Hi

  1. Do you have the hyperpixel-overlay.dtbo file in /boot/overlays = yes

  2. enabled in /boot/config.txt = Don’t know what am I looking for i.e exactly what should it say?

  3. What happens if you: ls /dev/i2c-* = /dev/i2c-2 /dev/i2c-3

regards
J


#8

Did you get any output from cat /var/log/hyperpixel-touch.log? It may be that the touch driver (written in Python) is failing to start, or crashing due to a missing dependency or otherwise.


#9

Hi

cat /var/log/hyperpixel-touch.log

2018-06-19 19:22:44.843948: Hyperpixel Touch daemon running…

regards
J


#10

There must be a missing dependency causing it to bail out, try running hyperpixel-touch manually and seeing if you get any error output.


#11

Hi just to recap

try running hyperpixel-touch manually = no errors

however sudo service hyperpixel-touch status = gives error
“Failed to start hyper pixel LCD touch screen Driver Daemon”

This is the sought of complexity getting it to work that will not work when I hand this to others in Africa, so If we can’t get it to work with easier steps than this, I would prefer to look for another device /solution and get a full refund.
regards
J


#12

This is certainly not the normal setup routine- what do you see if you run: sudo i2cdetect -y 3 with the HyperPixel installed on your Pi’s GPIO? Sounds like there’s something up with i2c comms or the hardware.

I have a suspicion your board is faulty and the hyperpixel-touch script is failing when it tries to communicate with it rather than due to a configuration/software issue.


#13

Hi

How do I get a full refund?

regards
J


#14

Drop an email to support@pimoroni.com with your order number and let them know it’s faulty. They should sort you out from there!


#15

Putting a link to this forum thread in your support e-mail won’t hurt either. ;)