Hyperpixel display show nothing


#1

I have hyperpixel 3.5” screen , i have intall the drive on raspberrypi zero with oneline intaller but the display screen goes black and show nothing. I have chack hiperpixel-init.sevice but it say inactive(dead). Any help please!?


#2

Did you run the old installer, or the new one for the 4 inch Hyperpixel? It may make a difference? I’m not sure if the new installer works for both the old and new display?


#3

I believe this is what you want for the 3.5 inch screen.


And this for the 4 inch


#4

I run the 3.5” installer
curl https://get.pimoroni.com/hyperpixel | bash


#5

Ok, just for the record I don’t own a hyperpixel.
Male header soldered on the PI Zero? Or a hammer header?
Hyperpixel firmly attached to the GPIO header?


#6

What is the current rating of the power supply your using?


#7

Yes , my PI zero was WH model , that has male header soldered from factory , and i attached firmly to the hyperpixel.
I’m using phone charger with 5.2v output


#8

I had run systemd manually sudo systemctl enable hyperpixel-init.service and it say failure


#9

5.2 Volts is good, you need lots of current too though. I do believe they recommend you use the official power supply that is rated for a max or 2.5 Amps.


#10

Did you get any errors when you ran the original one line installer? Maybe try running it again?
Are you running full Raspbian, or Raspbian lite?
Anything showing on a monitor connected to the HDMI connector?


#11

I almost tried clean install of os and run hyperpixel intaller script and still can’t show nothing, mybe the installer is the problem


#12

Do you have an HDMI screen connected? If yes are you seeing a flashing lightning bolt symbol on screen?


#13

Hi Ptruckstar,

Do you have any error messages or anything?

Please could you paste in the text you get when running the one line installer?

Finally, please could you attach a picture or two showing how everything is connected?

That’ll help us get to the bottom of what’s going on and help you get this all working :)


#14

@Matt And the fresh install again.
Sorry I’m forgot to copy the script text but I attaching a screenshot.


#15

Im not use HDMI yet because I don’t have mini HDMI connector.
I set that all with ssh.


#16

Do you have anything else enabled in /boot/config.txt which could be conflicting the pins HyperPixel needs (pretty much all of them)?

Do you see anything useful in the outputs of dmesg or systemctl status hyperpixel-init?

What happens if you run hyperpixel-init directly over SSH? sudo hyperpixel-init


#17

I did that but still


#18

Status of hyperpixel-init


Dead??


#19

sudo hyperpixel-init do nothing

I tried run service manually too


#20

Could you check /boot/config.txt

Also what’s the output of lsb_release -a and uname -a?