Install problem picade

Hi
Bought a used picade.
Get the following error when I run “curl sS https://get.pimoroni.com/picadehat
“…E: Repository ‘https://raspian.raspberrypi.org/raspian buster InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’ Apt failed to update indexes!”

The gpio is working in ‘wiringpi’
Hardware = RaspberryPi A3 + Retropie = 4.7.1

Joystick and buttons not working. What can I do?

I “think” what you have to do is run
apt-get update
and
apt-get upgrade
and answer y (yes) when prompted about the stable, oldstable.
Then run the installer again and see if it works,

I’m getting the same, new picade x new joystick and buttons.
did the apt-get update and apt-get upgrade and still get
“…E: Repository ‘https://raspian.raspberrypi.org/raspian buster InRelease’ changed its ‘Suite’ value from ‘stable’ to ‘oldstable’ Apt failed to update indexes!”

feels like i’m going round in circles

The issue is, as I understand it, that Debian have released Bullseye.
That means that eventually, likely in a couple of months, the Pi Foundation will release a new version of Raspbian AKA Pi OS. So along those lines, Buster went from stable to old stable.

Long story made short, you have to acknowledge the change when prompted with a “y”. Depending on how you get that prompt, it may not be possible to type the Y.

You may have to exit to command prompt and run apt-get manually.

how do we do this?
I’m new to this but learning quickly

I’m not running Picade, but as far as I know there is an “exit to command prompt” option in there. It’s how you edit config.txt etc.

EDIT:
Hit F4 on the PC keyboard, this should drop you into the raspbian text console

yeah, obviously I got that far, else I wouldn’t have been able to attempt the previous steps.
I also know how to ssh into the pi.
“curl sS https://get.pimoroni.com/picadehat” doent work

git clone https://github.com/pimoroni/picade-hat doesnt work as its asking for username and password

I use “git clone” all the time and have never been asked for a password?
It’s how I get the example folders for all my breakouts etc.

ssh in and try running apt-get update and apt-get upgrade.

EDIT: Apologies if I missed something, real world distractions in the background, as I replied.

$ sudo apt-get --allow-releaseinfo-change update

This worked for Me.

1 Like

Thankyou @Nichi I was looking for that but didn’t find it. I frequent the Pi Foundation forums but don’t always remember what I see etc. Getting old I guess. ;)