Picade 10" not detecting joystick or buttons

I’ve had this console for a couple of years, and have just swapped out a Pi4 2gb for a Pi 4gb, and updated the install to the latest version 4.7.1 for Pi4/400, and it booted straight up with the screen working, so all good. I got to the Configure screen and pressed a button on the console, but it wasn’t detected. Pressed F4 on my USB keyboard (back panel is off), and tried the “curl https://get.pimoroni.com/picadehat | bash” and I got an error stating that buster had been changed to “old stable” and it failed. Rebooting proved it had failed, and sure enough the buttons didn’t work.

I tried “showkeys” and that wasn’t generating any keypresses either. Is it possible I’ve damaged my hat while I was handling it? It looks ok, but who knows? I’m certain the Pi is connecting to the wifi, but I’m not sure how strong the connection it, although I’d have expected a different error message if it was dropping it.

I’m a mostly Windows user, so be gentle with me ;)


Running sudo apt-get update and sudo apt-get upgrade should get rid of the old satble message. Running apt-get instead of just apt will get you a message about the change to old stable that you can answer Y (yes) to. Once you do that you can go back to just running apt. That’s a secondary issue though, that I don’t think is related to your problem.
Double check your wiring harness to make sure a wire hasn’t come lose, especially a ground wire. Wouldn’t hurt to reseat the hat too while your at it.

Weirdly, using sudo apt update and sudo apt upgrade worked, while apt-get didn’t give my the y/n prompt. With that done I rebooted for it to take effect, then went to get the picadehat using curl https://get.pimoroni.com/picadehat | bash and rebooted again.

Now the weirdness starts. On booting I get a rainbow screen that takes up the full height and about 3/4 of the width (centred), then the usual scrolling of packages and such streaking past, then a black screen. Nothing doing. When I hit F4 to quit out though, I get the Picade info with the text-graphic, and my usual prompt.

I noticed something about uncommenting a HDMI command toward the end of the picadehat install, and wonder whether that’s screwed up my display settings. More Googling required, I think.


Figured it out myself by plugging the MicroSD card into my PC and re-commenting the bits in config.txt I thought I’d seen flash past my screen. It also identified my controls on the console, so I think I’ve got further than I ever did before. Result :) Now to load some of the old games I was involved in so I can show my son how crap I was at graphics and game design :S