New build 10 inch picade, many problems i can"t fix

#1

Hi everyone both crew and forum members.
i’ve built my new picade 10 inch screen. I have a few issues i cant seem to resolve. even with the many finds on this forum.
after i build the case
i went into the config to uncomment hdmi_force_hotplug=1 and the screen is going.
i put on the wifi
i went into f4 to put in the " curl get.pimoroni.com/picadehat | bash " installer line.
i put in the sudo apt install wiringpi (saw that on the forum, now i could at least get some buttons to work)
i added dtoverlay=picade in the config file
and i added the roms i wanna play. so far so good.

BUT… the following things don’t work:

  • the joystick ‘up’ doesn’t register (left right and down work fine)
  • 4 out of 10 buttons don’t register (the other 6 work perfectly)
  • the sound does NOT work at all.

PLEASE somebody help me? I am completely new at linux and the only reason i bought this was because i saw the building tutorial and it only needed the one line input… yet now it seems to be so much more difficult (for me) to get it right. i am completely in over my head and i don’t know how to fix it. i have checked the wiring again and again… but i cant seem to find any misstakes or loose ends. I would be very gratefull to get any help someone can offer…

All the Best, and thanks again for anyone willing to help in advance, Daan.

0 Likes

#2

The installer is supposed to add the “dtoverlay=picade” line to the boot/config.txt file, so if you had to do that manually it suggests that the installer didn’t run properly. I would try to install the software manually, or ‘automatic’ as the github site calls it:

If you do that, when you run the install.sh script you should see some output telling you what it did. This is what I got:

Notice: building picade.dtbo
Notice: copying /boot/config.txt to /boot/config.txt.picade-preinstall
Installed: /boot/overlays/picade.dtbo
Installed /etc/udev/rules.d/10-picade.rules
Installed /etc/asound.conf
Config: Added "dtoverlay=picade" to /boot/config.txt
Config: Added "dtparam=audio=off" to /boot/config.txt
Config: Uncommented "hdmi_force_hotplug=1" in /boot/config.txt
Installation finished. You must reboot for changes to take effect!

Try that and see what happens.

0 Likes

#3

i will get on it as soon as i get home tonight. thank you so much for replying!

0 Likes

#4

of course I am super thankfull for the effort, unfortunately it didn’t change anything for the better (or for worse).
Still no sound, still no ‘up on the joystick’ to register and still only 6 out of 10 buttons register… here is an image of my results after taking your advice:


what can I do now? of course i rebooted after all of it… :)

0 Likes

#5

Have you pressed the buttons when you have a command prompt? You should see a character appear for each button, except game buttons 1, 2, and 4, which are Left Ctrl, Left Alt, and Left Shift respectively.

For the sound, I assume you’re talking about the speaker wired to the X HAT? Obvious question first, have you checked the system volume to make sure it’s not zero?

0 Likes

#6

i (double) checked the system volume setting. it was fully open. too bad, would have been great if it was simple as that :). I must be honest i did not check it before, but too bad, still no sound.
apart from left, right, and down on the joystick it registers the buttons as following:
left control, left alt and left shift (as you mentioned)
the "O"key
the “Z” key
and escape (i noticed that in the configure input menu option)
joystick up, and the other buttons dont register at all, also not in command prompt.
any idea what i could try next?

0 Likes

#7

OK, check this thread for discussions about similar problems to yours:

In particular, I’d try the watch command from that thread, which will show you the GPIO activity, and my give you some more clues.

A couple more questions…
1 Are you using a standard image, downloaded from the RetroPie web site?
2 Have you done an update on the system (RetroPie > RetroPie Setup > Update)? If not, I’d uninstall the picade software, reboot, do an update, reboot, re-install the picade software, reboot.

0 Likes

#8

i used a fresh retropie image downloaded of the official website just a few days ago (like they tell you as a preferred method). I did it once without updating and started once from scratch with updating before installing the pimoroni software. I have checked the page you refer to already before posting my issues but it wont get me any further…

I am not sure where to look next… i do thank you for your time and effort… you seem very nice to put in your goodwill simply to help someone online.

0 Likes

#9

Hardware person here. Can we check connections to the arcade switches (no metal showing between wiring harness and switch) and header connections to the HAT (pushed down fully flush)?

0 Likes

#10

Hi Monglet,
First of all thank you so much for also stepping in. Very much appreciated!
I have checked again and again… but hey let’s hope i did make some mistakes here because a solution would be so much closer, To be sure, and to let you check with a lot more knowledge on this subject I took some pictures:



If you need to see it from another angle, ofcourse just let me know… and i will show it as clear as i can… Is there anything i done wrong as far as you can see? (the usb dongle is for my keyboard)

0 Likes

#11

Have to say- hardware all looks good.

0 Likes

#12

dang… really hoped i slipped up so i could localize the problem… well, thank you so much for checking for me.

0 Likes

#13

Daan87, what were the results when you ran the ‘watch’ command from the other thread? Did all the buttons and joystick directions produce a response?

0 Likes

#14

Hey mironc :) i will run it directly after work and post tonight. i think i ran it but i am not sure at the moment. ill let you know! thanx again.

0 Likes

#15

i just ran the watch command, i get no respons from the joystick up or the butons that wont work in the configure input menu in retropie. while the other ones that do register simply show a respons in the program. i dont think it would help, but if it does i could make a small video so you could see there is no response and post it (through youtube link for example). so if it would help, just tell me and i will post it.

this means, if i am correctly, it’s not a ‘remapping’ problem/solution. or did i misunderstand your logic behind this question?

0 Likes

#16

The only thing that’s a bit odd about the hardware (having looked at the photos again) is that the hat is sitting quite high up off the pi. Squish it squish it squish down?

1 Like

#17

let me try at once… god i hope you are right… im back in a few minutes :)

0 Likes

#18

oh my god i am SUCH an idiot!!! that is it!!! thank you SO much! it is my first electro project… and i thougt i would break something if i dit that… okay i am so so thankful to you my friend!

Monglet and mironc… thank you both so much for the time and effort!!! i am ever so thankful for both your help. also the audio is working and the button config went perfectly

1 Like

#19

Glad to help (although I wasn’t much help in the end!) Enjoy your Picade.

1 Like

#20

you were willing to help… that’s what matters! thanx again, i am enjoying it a lot so far!

0 Likes