Issue with Picade console + Rasp Pi2 + Retropie


#1

Hi Guys,

I just got my picade console and it definitively looks great.

I built it up using the video instructions and it went smooth through :-)

I installed now Retropie 3.5 on an SD Card and try to run it using the Picade console. Here I’m facing some issues :-(
As many of use posted to confirm that it works like a charm, I tough you may give me some tips :-)

Basically at first boot the console is not recognized by Retropie. So holding one button makes it discovered as a keyboard. At that point I can configure the key mapping through the UI which works fine.

Once in EmuleStation the buttons and the stick work properly. The issue come when I start a ROM where the pad and buttons are not recognized anymore…
Looking to /tmp/runcommand.log shows the following:

Core: Country: Europe (0x50)
UI-Console Status: Cheat codes disabled.
UI-Console: using Video plugin: ‘Mupen64Plus OpenGL Video Plugin by Rice’ v2.0.0
UI-Console: using Audio plugin: ‘Mupen64Plus OMX Audio Plugin’ v2.0.0
Input Error: Couldn’t find config file 'InputAutoCfg.ini’
Input Warning: missing ‘plugged’ parameter from config section AutoConfig0. Setting to 1 (true).
Input Warning: missing ‘plugin’ parameter from config section AutoConfig0. Setting to 1 (none).
Input Warning: missing config key ‘DPad R’ for controller 1 button 0
Input Warning: missing config key ‘DPad L’ for controller 1 button 1
Input Warning: missing config key ‘DPad D’ for controller 1 button 2
Input Warning: missing config key ‘DPad U’ for controller 1 button 3
Input Warning: missing config key ‘Start’ for controller 1 button 4
Input Warning: missing config key ‘Z Trig’ for controller 1 button 5
Input Warning: missing config key ‘B Button’ for controller 1 button 6
Input Warning: missing config key ‘A Button’ for controller 1 button 7
Input Warning: missing config key ‘C Button R’ for controller 1 button 8
Input Warning: missing config key ‘C Button L’ for controller 1 button 9
Input Warning: missing config key ‘C Button D’ for controller 1 button 10
Input Warning: missing config key ‘C Button U’ for controller 1 button 11
Input Warning: missing config key ‘R Trig’ for controller 1 button 12
Input Warning: missing config key ‘L Trig’ for controller 1 button 13
Input Warning: missing config key ‘Mempak switch’ for controller 1 button 14
Input Warning: missing config key ‘Rumblepak switch’ for controller 1 button 15
Input Warning: missing config key ‘X Axis’ for controller 1 axis 0
Input Warning: missing config key ‘Y Axis’ for controller 1 axis 1

I tested with a standard keyboard in USB on the Pi and it works fine.

So did I miss something or is there any issue between the PCB and retropie 3.5?

Thanks a lot for any advice.

Kaz


#2

Doing more testing by editing the configuration file to add the input configuration, I found something additional in the log file:

Input: 0 SDL joysticks were found.
Input: N64 Controller #1: Forcing default keyboard configuration
Input Error: Couldn’t find config file 'InputAutoCfg.ini’
Input Warning: missing ‘plugged’ parameter from config section AutoConfig0. Setting to 1 (true).
Input Warning: missing ‘plugin’ parameter from config section AutoConfig0. Setting to 1 (none).
Input Warning: missing config key ‘DPad R’ for controller 1 button 0
Input Warning: missing config key ‘DPad L’ for controller 1 button 1

Could it be that in Emulstation the Picade is seen as a keyboard but in the “game” as a joypad? This could explain why the inputs are not matching anymore, no?


#3

I have had Mupen64Plus running using the new Picade firmware as a HID Joystick, but that’s standalone. RetroPie does some weird, weird stuff.

You can get your hands dirty in the configuration file by editing it directly, and making sure it’s set to full manual mode rather than automatic. Mupen’s config file format is weird, though, it uses button(n), axis(n,n), hat(n) and key(n) in its config file as seen in this long, long auto-config file: https://github.com/mupen64plus/mupen64plus-input-sdl/blob/master/data/InputAutoCfg.ini

If you’re in the position to do so, try the new Picade firmware and use the Python library to push it into Gamepad mode (sorry I haven’t written a config utility for it yet) and save.

You’ll need to run: ./update picade_2016.hex