Keyboard config "OK" not working

Hello Picade community,
I have just received my new Picade (rasp 4, 10")
and successfully assembled it following the instructions from the YT film

My sequence of actions:

  1. My screen comes on
  2. Pushing “A” or spacebar, as shown in the video does nothing
  3. I can not get to this screen

I can select “configure” and see the keyboard configuring questions.
So I have configured most of the relevant keys on a wireless Rii mini x1 keyboard. (Using a microsoft wireless keyboard & mouse combo didn’t work at all for some reason)

Clicking OK doesn’t work. At least: I get no response on screen. I see or hear no signal telling me it has successfully saved. I expect to be moved to the next screen, per the video. Alas, nothing.

The key I configured to “select” was the “returnkey”
The only option out of this screen is F4, which takes me to the cmd line.

(I have tried re-doing the install with Balena etcher and starting from scratch. I had to change the config file and uncomment “hdmi_force_hotplug=1” but that is only for the screen.)

On the cmd line I get a message “wifi is currently blocked by rfkill”

I added a wifikeyfile.txt with my wifi credentials, but that hasn’t changed the rfkill message

Looking online: this forum,, has me spinning with all the new technology words & concepts.

Any help is most appreciated,

Definitely worth trying a standard USB keyboard rather than the rii wireless, just to see if that makes a difference. Also which version of retropie are you using, is it the vanilla one from the retropie website or is it a preconfigured image from somewhere like arcadepunks? If the latter, please try standard retropie.

Hi @Matt
Ok I used a wired keyboard
Same problem. Nothing gets the OK button to submit.
the retropie I use is “retropie-buster-4.6-rpi4.img.gz”
It’s not on top of any other OS, just straight to the 32GB data card.

NO! Hold your horses !
Using a wired keyboard worked

Glad to hear it :) Have you been able to get the joystick and buttons working as well?

Yes, they seem to work.
But I can’t get any game to start. Tumbleweed game loading screen shows up. Then pushing start brings me to a screen called “sound test” the only thing that works there is joystick right, which raises the number “of the sound test.”
Nothing else happens.
I loaded mame2003 and added pacman. But no game shows, only the option to select pacman.
Where to even start looking for a solution to such a bizarre error?

@Matt can you help steer me in the right direction on this issue?

Try the RetroPie web site for help with getting games to run. Arcade games (mame) are a minefield, and they have their own section in RetroPie’s docs page.

I followed all the steps as given in the instructions, both on the pointed sheet as well as the step-by-step Youtube video.
Here is what happens when I boot up:

Should I reinstall perhaps?