Major sound problems


#1

Hey guys new to the site. Well I bought the picade for my girlfriend and she was in love with it when it arrived. Followed installation guide done to the bone.(even added the additional text of code forcing the hdmi screen) Once it booted up for the first time the sound comming from the speakers would just hiss. No actual sound would cone from the system. I tried adding the exception in the config text but nothing happens (I did save it). Any help would be appreciated. I can not return it since it was bought december 27 2015 on the adafruit site.


#2

have you tried adjusting the volume as recommended here:

http://forums.pimoroni.com/t/sound/806/11

If that does not help, please post your exact /boot/config.txt… stating that you added unspecified bit of code we simply can’t tell whether they would matter, improve or degrade the situation!


#3

There are a lot of factors that can affect the audio, the simplest first thing to do is to increase the volume in emulation station to about 95 and to decrease the volume on the picade.

The other big factor is the interference you get from the audio cable from the picade board to the pi, make sure this is routed away from power and hdmi cable, this perhaps should be shielded as if you move it around you’ll likely hear interference just by touching it or moving it slightly, not ideal at all but with a bit of fiddling and adjusting (there’s an audio dither option for the config.txt you can add too) it can be adequate.

Ideally sound would be perfect through hdmi but that’s not so easy to route through the display adapter.

I dismantled an old set of PC speakers (including amp) and built this into my picade - they sound a bit more powerful and bass-y with analogue volume and base adjustment.

Also, you can get a USB audio adapter for about £10, this also completely gets rid of any hiss however there’s a little work to do in software to get this as the default output, it also limits the n64 emulator as one of the display plugins (rice I think - or glide) is incompatible with the sdl2 sound plugin required.

… mainly though, check your wiring and adjust your volumes