Sound


#1

Put the Picade together, went like an absolute charm, got Retropie running nicely. Forced sound output through the 3.5mm jack, but I am getting a lot of ambient noise/hiss when no sound is playing. Anyone else experienced this?


#2

You may possibly need to turn the Picade volume up and the Pi volume down slightly. Or vice versa. The Pi’s analog sound output is pretty noisy at the best of times ( par for the course with such a small computer ).

Also double-check that your 3.5mm cable is pushed fully in at both the Pi and Picade end- I’ve left it hanging half out so many times I’ve lost count.


#3

I would be tempted to get a cheap usb soundcard perhaps - it is difficult to eliminate all the noise from the pi’s analogue audio.

on the older Picade Maxi as part of the kickstarter project, it was possible to take the audio off the LCD controller board directly to the speakers, which works well, as it’s audio source is fromthe hdmi. Not sure if that’s possible with the new model.


#4

sudo nano /boot/config.txt

then add:-

disable_audio_dither=1


#5

I’d be interested in hearing from anyone who tries this!


#6

It really removes 98% of the horid static output from 3.5 header.

Spacemonkey


#8

I can confirm this improved the sound issues (static) that I was hearing.


#9

Just seen this: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=136445
on the raspberry pi forums.
May help with some of the audio issues?


#10

Came here to post exactly that. It will be interesting to see how it fares in a Picade setup.

I very strongly recommend against rpi-update unless you really know what you’re doing, though. You never know what might be broken in the experimental pre-releases. Thar be dragons! If you value your configuration, back it up with Win32DiskImager or otherwise.


#11

I found this thread googling for “Picade sound hiss” so thought I’d post my solution. In my case the raspberry pi alsa volume setting was too low. I quit emulation station, typed “alsamixer” and then increased the volume from 12 to 50. This resolved the hiss.

The alsamixer controls can also be accessed from the “configure audio settings” menu by selecting “mixer - adjust output volume”.


Major sound problems
#12

5 posts were split to a new topic: Picade HAT Poor Sound Quality


#13

Hi Rogue. Sorry for delay…Work…

I am using Raspberry pi powerblock, plugged into the picade hat, thats stuck on top of the pi3. Slightly raised I guess as its on a pibow case too.

There is a heat sink on the pi, but it doesnt get near the picade…Not as far as I can see.

Nothing into USBs, only a 360 xbox USB controller for setting up.

All fairly standard… What i can say, is that the sound is better now I have done a clean install, BUT I am still getting this overrun error. I have a speaker plugged into the picade, its probably a little big (8ohm) but regardless of that being plugged in or not, it doesnt make a difference to the error being seen when I shut down…

Maybe try a new picade? I never used to see this before, seems to have just come on…