Motioneyesos suction camera holder


#1

I have a rasperry Pi Zero loaded up with the motioneyesos and also the wpa_supplicant.conf file.

I am now looking for a suction camera holder, like the ZeroView one which not currently available from anywhere I have looked.
What similar camera holder would do the same job


#2

There is the Octocam, https://shop.pimoroni.com/products/octocam-pi-zero-w-project-kit
I don’t think you can buy just the suction cup part though?
If you mount the Pi Zero to a Pibow difusser , https://shop.pimoroni.com/products/pibow-modification-layers?variant=1047618757 with double sided sticky pads.
Then use some of those suction cup holders with the hooks on them to hold the difusser. The ones for holding stained glass ornaments etc in windows. Best I can come up with at the moment.


#3

Thanks for the links, but what did you use for the same project.

I don’t know yet what to use, although I have got a diffuser which I bought for some Pimoroni blinkt and scrollphat project, but the screws were not long enough.
I’d have to drill an hole in the middle of the diffuser for the camera.


#4

I did this,


https://1drv.ms/f/s!AjOYwiwlwDtpgtIa6dhTBqnE9W-LcA
No suction cups just free standing.


#5

That looks just the job.
I have the pi camera, wide angle, but with just a short connection ribbon 2 inches max lenght.
I am just trying something with a couple of stand offs in 2 holes on the Pi Zero, and then 2 long screws, in the other 2 holes, with wire sheathing cut to the right lenght, for spacers. I don’t have enough nuts for everything otherwise.
I’m going to have to put the camera near one end, due to a short ribbon.


#6

The screws to mount the camera are the hard ones to find, I used the ones that came with this,


I had already broken the base part so it was just sitting there doing nothing.
Insulated hookup wire will work too. It may not look the best but it will hold it in without shorting anything out in the process. Just put a knot in the wire for a spacer.

I got lucky and got a whole bunch of long screws that fit those Pi stand offs from a dead laptop.

I mounted a version 1 camera in the official Pi Zero case. I had to enlarge the peep hole so the camera snapped in snugly though. It was the only way I could get it to snap in firmly, without maybe breaking it?


#7

Yes, I see what you have done , kind off hung camera/holder underneath.
I also have loads of laptop screws, from ones I have stripped down and binned most of the hardware. The trouble is, I don’t have the screw to go with them now.

What I have done is drilled a 6mm hole in the pi zero diffuser for the camera body, but not the square part of the body.


#8

Yeah, you have to get creative some times. Finding cases to fit what you build has always been a problem. Unless you own a 3D printer, which I don’t . :(


#9

No I don’t have a 3D printer either, as I couldn’t justify the cost. Right next job is to find some of those suction cup holders, which shouldn’t be difficult. then I could stick them to a window or whatever else and place the diffuser thingy onto the actual hooks.
Trial and error situation time methinks.


#10

Well you wouldn’t believe this but after powering up the PiZero the the motioneyesos, it would not boot up, and no flashing led either. I took out the card and popped into a usb / card device so that I could look at it and see what files were then.

No card was recognised, and in windows diskpart the 16gb card has a 0mb partition and a 32mb partition. That’s another card a PiZero has screwed up. I wouldn’t mind but it was working fine previously.


#11

I’d be more inclined to believe its a Motion Eye issue versus an issue with the Pi. I’ve had a few similar things happen with motion eye. Not lately, knock on wood. I’ve had to redo a few cards via diskpart to make them usable again after putting motion eye on them.


#12

If you mount the Pi in a Pibow case, you can then use the long bolts, https://shop.pimoroni.com/products/pibow-extender-bolt-pack to mount the difusser. If you only use two of the long ones you should have enough nuts to hold everything in place. .


#13

I found that I had to use the 20180224 image for the Zero, as the other builds didn’t boot up as they were for the rpi3, so when image was burned onto the new sdcard, motion eyes booted up to a login box. Great, but my raspberry Pi camera is not recognised. Yes I have taken out the ribbon cable and re inserted it, making sure it was all the way in, but still no joy.
Did your camera work straight away, or did you have to install any extra files etc:
like loading the bcm2835-v4l2 kernel module, by adding it to /etc/modules and rebooting afterwards. From:
https://github.com/ccrisan/motioneye/wiki/Troubleshooting#raspberry-pi-camera-module-not-detected.

Thanks


#14

There should be 3 Motion Eye images for the Pi. One for the Zero, one for the Pi 2, and one for the Pi 3. Make sure you use the correct image.


I’m currently running the 06 27 image on Pi 3 and 3B.
I did briefly run Motion Eye on a Pi Zero W, don’t remeber what build it was though? Camera worked without having to do anything special. I had to connect a USB HUB with ethernet to log in and setup my WIFI.
I had one camera not work but reseating the ribbon cable fixed it.
My cameras are the Official Pi foundation cameras, 1 version 2 and 2 version 1’s.


#15

Yes I see from the link that the Pi Zero is supported, but the 0627 build only booted as far as the rainbow coloured square, and wouldn’t go any further, so its the 0224 image I have put on the sdcard.

Blimey, I didn’t realise there were so many pi cameras about!
This on Amazon is the expensive version:

Which looks like this one:

Is either of those the one you have, as I have googled Official Pi foundation camera, and the Pimoroni one was in the list of links.
The Amazon one is v2.1
Thanks


#16

OK, just wanted verify you downloaded the Pi Zero image. I found that the Pi Zero wasn’t up to snuff as far as streaming video goes. Too much lag and stuttering.

I have one of the V2.1 ones, I bought from Pimoroni. My other two are the original version 1 cameras that were first released. V1.3 I think? Same size and shape, same ribbon cable connector, just less megapixels.
https://raspi.tv/2016/new-and-old-raspberry-pi-camera-comparison-shots-1-3-2-1-noir


#17

Yes it was the PiZero image 0224, which I used. The v2.1 camera seems to be the best image from the link. Dya know I may well push the boat out and go the Pi3 way with the 2.1 camera, which is not in the listing of cameras, weired.


#18

Which listing of cameras?


#19

This one:
https://shop.pimoroni.com/?q=official%20raspberry%20pi%20camera

I’ve just took the camera ribbon out of the pi zero and re seated it again, but it’s still not recognised. I did but it from here a few months ago and it did work with another project I did.


#20

Ok, yeah weird that its not listed? It will be if you just search for “camera”
https://shop.pimoroni.com/?q=camera
Its this one, https://shop.pimoroni.com/products/raspberry-pi-camera-module-v2-1-with-mount?variant=19833929735