Motioneyesos suction camera holder


#121

CSI is the Camera Serial Connector, the ribbon cable connector. The other one is the DSI, Display Serial Connector.
I would think you should see the messages in the terminal window. If not try running the python file from Idle, F5.


#122

Ok so is CSI the same connector as the one nearest the USB and ethernet ports. I didn’t remove it from that position when motioneyeos was running on the same pi.


#123

Yes, it will have Camera next to it. And Display marked by the other one. The DSI is for the Pi foundation 7 inch touch screen. Just wanted to make it was the Pi foundation camera and not a USB camera etc.


#124

I had to re flash the sd card because when I connected a monitor, there was a white band down the left side and no menu bar at the top.
I then copied te python script back and now it doesn’t run.

A bit of invesigation required methinks, but not now tho’


#125

Did you run
sudo apt-get install python3-picamera


#126

Yes I did actually, and it returned already installed or similar.
Since then formatted a 16gb sd card, installed raspian on it, then it updated itself, rebooted, enable ssh and camera and copied the python script from a usb stick to the specified folder on the pi. This time the script did run, but still no files were produced.

After I saved the script in IDLE as a py file, the heading on the IDLE window is now Python 3.5.3 Shell path tp the saved py file Pressing F5 does nothing.


#127

With the file open in Idle, go to Run and in the drop down menu you should see “Run Module F5”. Click that to run it and I do believe any print commands will show in the new window. The one where it says restarting etc. I think anyway? You’ll see error messages there for sure if the file errors out.
Pressing F5 is supposed to be a quick way to run the file. Focus may have to be on that window for it to work though?


#128

Ok I managed to get the Run menu up now, by closing Idle and reopening the file.

When I now press F5, it opens up the Python Shell window, with nothing in it???
Oh and an error message saying Invalid Syntax. Well it would if there was nothing to run.
Weird or what.

Could you try it as well, just see if it works for you and not me


#129

The syntax error will tell you what line in the file thats open “in the other window” has the error.
If you click Run and then Check Module, that should point you right to the error.


#130

Mm, I’m afraid it doesn’t point to anything after clicking Check Module and getting the Syntax Error message box up.
ok, I’ve sorted it now. The syntax error message was on a copy of the python script which I named sec_cam.py, whille the original is security_cam.py.
The original script now throws up a few lines of errors when I clicked on run module.

A couple of the said lines/errors are : Failed to enable connection.


#131

You’ll end up with two boxes / windows. The Idle window you opened your python file in. And a second almost empty window when you do the check module or Run.
If the file runs without error you won’t see anything in the new window. If it does error the error message should point to a specific line in the file.
Running check module should get you the same error message but also highlight where the error is.


#132

I clip and pasted the code from that site I linked too into Idle and saved. Running check module doesn’t show any error. I can’t run it as I’m on my Windows PC.
Well I can run it but it will just error out with a module not found.


#133

It w as down to one of the jumper wires not inserted all the way in the hole on the board, so I guess that was the casuse of the error messages, as now there are no errors.
I’ll get the script running and leave it for a few hours or so to see what the outcome is.


#134

You’ll want to walk in front of it every now and then or maybe wave your hand in front of the sensor. Something to trip it and have it take a picture.


#135

Oh yes, I know that it requires some kind of movement in front of the sensor.
Unfortunately it doesn’t work. I have managed to contact the author of the project, and he has no idea as to why it does no work. He also suggested that I try it in IDLE rather than a shell, and it is doing that now, and only showing a flashing cursor.
I will investigate this a bit further if I can, and hope to resolve the problem. The only thing I can think of right now is that the sensor maybe faulty, but I have had it working in another project.
If you can get it working ok, please let me know how you did it.


#136

I don’t have one yet. I will be ordering that Pimoroni one with the extra header on it in a few days. If it’s Pi compatible I’ll have a go and see how I make out.
https://shop.pimoroni.com/products/ultrasonic-distance-sensor-for-robo-bit-mk2
I’m also going to order one of these,
https://shop.pimoroni.com/products/vl53l1x-breakout
And play around with it. I’ll test it on a Pi first, then see if I can get it working with an Arduino.


#137

Yes ok, let me know how it works when you do it please.
I have been checking the volatges from GND to various points or pins on the board and what puzzles me is that between GND and the PIN 18 wire there is 0 volts.
Whereas other points give / show 3.3 volts.

I have sent the information I found to the author for clarification etc.


#138

Make sure your connected to the correct pins, he setup as GPIO.setmode(GPIO.BCM)
For example BCM 18 / GPIO 18 is physical pin 12 on the GPIO header.


#139

OMG, that was the cause ov the problem. I was using PIN 18 and not GPIO 18, Doh!!
I read Pin 17 and 18 rom the picture o the sensor connections.
Only iv I had read further down that it was GPIO pins 17 and 18.

It is now working, phew!


#140

That confuses a lot of people, me included when I started using my first Raspberry Pi. I still find myself double checking hookups before powering up. At least no harm was done. I have a nice carboard card with it all marked on it I got with some stuff I ordered from CanaKit a while back. I keep that Handy. Plus a link to the pinout page I posted above.