Need Help ! Pimoroni on a Pi4 w/ Pihole and PADD

As the above says…
I have a Pi4 w/ Raspbian and a Pimoroni also running PADD

If you have this you know what it is :):)

Anyways once I set up Raspbian I had to goto to prefs and set screen rotate…
The program im running on TOP of PIHOLE is called PADD… its a STATS Screen looks like it is a console window… BUT its running in PORTRAIT MODE… anyone know how to change it and make it run in Landscape mode ?
thanks in adv.

I used to do it on my Pi Foundation Touch screen via a config.txt edit
lcd_rotate=2 to flip it 180 and also flip the touch 180
These days in Buster, you can do it via the Raspbian GUI. Looks like that didn’t do it for your program though so I’ll post the old way.
I’m guesing you’ll want lcd_rotate=1 or lcd_rotate=3.

Ill EDIT the config.txt in a few mins and try it (thanks !) I tried what it said on pimoroni… something like… hyperpixel4rotate left
and that didnt work after a reboot ;(
and ill let ya know :)

It didnt work for me ;( remember im new here w/ linux… here is a COPY of my CONFIG File… I edited it in NOTEPAD on my PC Put card back in PI, rebooted…

For more options and information see

http://rpf.io/configtxt

Some settings may impact device functionality. See link above for details

lcd_rotate=1

uncomment if you get no picture on HDMI for a default “safe” mode

#hdmi_safe=1

uncomment this if your display has a black border of unused pixels visible

and your display can output without overscan

disable_overscan=1

uncomment the following to adjust overscan. Use positive numbers if console

goes off screen, and negative if there is too much border

#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

uncomment to force a console size. By default it will be display’s size minus

overscan.

#framebuffer_width=1280
#framebuffer_height=720

uncomment if hdmi display is not detected and composite is being output

#hdmi_force_hotplug=1

uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_group=1
#hdmi_mode=1

uncomment to force a HDMI mode rather than DVI. This can make audio work in

DMT (computer monitor) modes

#hdmi_drive=2

uncomment to increase signal to HDMI, if you have interference, blanking, or

no display

#config_hdmi_boost=4

uncomment for composite PAL

#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

Uncomment some or all of these to enable the optional hardware interfaces

#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

Uncomment this to enable infrared communication.

#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on

[pi4]

Enable DRM VC4 V3D driver on top of the dispmanx display stack

dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d

dtoverlay=hyperpixel4-common
dtoverlay=hyperpixel4-0x14
dtoverlay=hyperpixel4-0x5d
gpio=0-25=a2
enable_dpi_lcd=1
dpi_group=2
dpi_mode=87
dpi_output_format=0x7f216
dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6

Try =3 instead of =1.
Any line in the config.txt with a # in front of it is ignored.
Remove the # and its acted on during boot up.
To be honest this is a bit of a stab in the dark, it’s just something I remembered doing way back when I got my first 7 inch touch screen.
You can edit it on the Pi itself.
From a terminal window run
sudo nano /boot/config.txt
Make your changes and press,
ctrl x
y
enter and reboot.

I do appreciate you trying to help :):)
it didnt work ;(
yea I do NOT have a # in front of the line lcd_rotate=3
I did find this page : https://github.com/pimoroni/hyperpixel4
If you scroll down to ROTATION I did that…

I can not see the underlying screen under the CONSOLE… I wonder if it is ONLY rotating that and NOT the TERMINAL/CONSOLE that opens up… Ive made a STEP BY STEP (in notepad) as to what I did to get this all running… and it runs fine… just when the TERMINAL/CONSOLE or whatever opens it opens in PORTRAIT not landscape…

I know when I installed raspbian, it was also ROTATED but I fixed that in PREFS or RASPBIAN before I installed “PIHOLE” and PADD…
I can PASTE here exactly what I did if youd like… but some was downloaded (liek PIHOLE and PADD was downloaded using terminal :)…
im all new to this linux…

It must be something to do with how PADD loads?
Just so you know, I don’t own a Hyperpixel and I’m not running PiHole etc. Just Buster on my Pi Foundation screen. And the way I have it currently mounted means I don’t have to rotate anything, its right side up in this case, not upside down like it was in my old setup.
Wish I could be more help but I’m also a bit of a NOOB where Linux is concerned. Most of what I know I learned the hard way, lol.

also if you scroll down to this : SirPottinger commented [on Jul 20, 2019]

on this page: https://github.com/pimoroni/hyperpixel4/issues/26

I got that same error (this was doing the hyperpixel4rotate=left)