No 3 second soft power down with picade hat


#21

There should only be one /dev/uinput

It looks like uinput is working- I’m not sure what’s causing picadehatd not to be running in the background at startup, since everything seems to be installed properly.

The uinput errors in the log file could have been a red-herring from running it as a user, rather than as root.

Try running: sudo picadehatd and seeing if that gets you up and running.

Absolutely, yes. The soft power off functionality requires picadehatd to monitor the pin state and issue a shutdown when it’s held for 3 seconds.


#22

Okay, so I ran a fresh install and the picade hat worked fine. Then I ran the install instructions for my Waveshare 4" monitor and then the hat stopped working.

Can someone look at these installation instructions to figure out why it is derailing the picade hat?

Thanks
-Rhad


#23

This part of the Waveshare install wouldn’t effect any of this would it?

"you should see dev/fb0 /dev/fb1
/dev/fb1 is your tft

if you don’t see /dev/fb1 you’ve messed up and need to start over
if all is good, now we get retropie output to your tft;

sudo apt-get install cmake
git clone https://github.com/tasanakorn/rpi-fbcp
cd rpi-fbcp/
mkdir build
cd build/
cmake …
make
sudo install fbcp /usr/local/bin/fbcp
now to launch fbcp automatically we need to add;

sudo nano /etc/rc.local
Before, the final “exit 0” line, add the following:

/usr/local/bin/fbcp &
ctrl+x then y then enter
"


#24

Looks like the power button pin for Picade HAT conflicts with the Touch Panel Interrupt on the Waveshare LCD? Is this the right LCD: https://www.waveshare.com/3.2inch-rpi-lcd-b.htm


#25

The monitor is only connected through HDMI not to gpio
here is screen https://www.waveshare.com/product/4inch-hdmi-lcd.htm

So it must be related to the software install process I am following for the lcd screen.


#26

Okay I seem to have solved the issue. The problem was with the software installation for the Waveshare 4" HDMI LCD screen I was using. I skipped the install and simply added the following settings to config.txt

hdmi_group=2
hdmi_mode=87
hdmi_cvt 480 800 60 6 0 0 0
dtoverlay=ads7846,cs=1,penriq=25,penriq_pull=2,speed=50000,keep_vref_on=0,swapxy=0,pmax=255,xohms=150,xmin=200,xmax=3900,ymin=200,ymax=3900
display_rotate=4.

Now the hat is working fine, powering on and off and the screen is working as well. Thanks to the pimoroni admin crew for helping me troubleshoot this one.