Picade HAT issues


#1

Hi

So, I just got the Picade HAT and I’m just trying to get started with it but i’ve encountered a couple of stumbling blocks:

I’m having issues with Powering the Raspberry Pi through the HAT, After a re-reading the description a few times I realised that if providing power through the HAT, you should then use the Power Button feature of the HAT to turn the Pi on… So far so good… So i rigged a quick push button up on a breadboard, connected to a ground socket and the power input on the HAT aaaaaaannd…
Pressing the button quickly causes the Pi to power up for about a second before powering back off.
Holding the power button allows power to continue to the device, but it stops the moment I release it… which obviously isn’t good.

My other issue is probably more me than anything. I saw on the description and on the little video you lot released recently that the HAT has a 3W DAC on there… Great… .(I know it has to do with Audio, but not much else) From what I can see, the Bundled version comes with a pre-soldered speaker… Which i assume is just a speaker, with a pre-soldered wire from the positive and negative terminals… Great… Where do you actually plug the speaker in? -_-

Looking at the HAT itself, I thought that it must be the + and - terminals beside the suspicious ‘Speaker’ icon… but then remembered that the board has Volume Control inputs, and all the other Ground terminals are marked as such instead of with the ‘-’ icon… So… Where might I connect my speaker?

Thanks a lot, sorry for being so wordy and hope you can help :)

UPDATE: So thinking on, I think RogueM is absolutely right about the speaker and I was just being an idiot, so no need to worry about that. Ive quoted the text because I thought it would be more useful than outright deleting it and can’t see a strike through formatting option whilr editing on my phone.

However, the power button is still problematic, any ideas?

Regards
Pete


#2

hum, I am not sure I would power the Pi through the HAT, what would be the advantage in this instance? either way I’m not clear about what you are wiring where so a picture might help.

incidentally the Picade HAT has no volume control inputs… are you sure you are not referring to instructions related to the ATchip-powered Picade PCB?


#3

Powering the Pi through the HAT allows you to make use of the soft power
on/off functionality.

As for the speaker… I may have my wires crossed (haha pun) mentally from
when I read the instructions to set the HAT up on their Github page…

I would take a picture, but there’s practically no wiring to show here…
literally, a button, with one wire to the terminal with the Power icon, and
the other going to a Ground terminal. and I havent wired the speaker up
because that was one of my questions.

Regards

Pete


#4

doh, I’m with you now!

I spoke to the engineer and his take on it is that it’s a faulty board. Can you contact support@pimoroni.com and request a replacement?

Ideally we’d like the board back to identify the fault and make sure it is caught within our current testing protocol… do you think you could return it to us?

That said, you may want to hang onto it until you get the replacement, particularly since with xmas in the way I’m not sure how long it’ll take to get a new board :/


#5

Sure thing, thanks for the help :) Merry Christmas~


#6

something just daunted on me though… could it be that the input row at the bottom of the HAT be touching the HDMI port, shorting something in the process?

I can’t see why you’d be able to boot by holding the ‘power’ input low (on BCM17 specifically), but I guess it is worth a try, maybe stick a bit of velcro (or any suitable isolating material) on top of the HDMI connector and see if that solves the matter.


#7

While I see where you’re coming from, I have tested this on a Raspberry Pi Zero first, (the HDMI port is nowhere near any of the pins in this instance… Then tried using a Raspberry Pi B+ as I wondered if I’d messed up soldering the headers onto my Zero and sadly the issue remained.

I’ve just tried your suggestion anyway with a post-it note and it still didn’t work, sorry :(

See the linked video: https://goo.gl/photos/BLYHCwjt6KJRKjzS7


#8

hum, OK, I will need to try on a Pi Zero, or B+, it’s a different Retropie image and perhaps that is relevant - can’t really see what could affect this side of things but perhaps that would explain why you received a board that seemingly passed our QA.


#9

I have the same power issue. Using the soft power causes the pi to boot for a few seconds then it cuts off.

To double check I installed mine on a mini black hat hacker as I thought the Picade hats pins might be touching something on the pi but the issue remains.

I shall contact support also.


#10

Could you try the following:

  1. power the Pi via its own microUSB (not through the HAT)
  2. boot up then exit emulation station (F4) or otherwise access the command line
  3. navigate to ~/Pimoroni/picadehat/picade-hat/
  4. synchronize the repository with: git pull
  5. cd inside the ‘eeprom’ folder, and run: ./reflash.sh

… then shutdown, and try to power up the Pi through the HAT.


#11

That seems to of fixed the issue! You’re a genius!


#12

Oh and Merry Christmas ;) I forgot as I don’t celebrate it.


#13

cheers, and thanks for confirming it works!