Picade X Hat Unresponsive

I recently received my order of the picade x had usb c and a few other accessories including the picade 8" screen, but I am having some trouble with them. I started by attaching a heatsink to the raspberry pi, then fitting the picade hat on top of it. Then, I attached a speaker, power button, and joystick. Since I haven’t made the frame of my arcade yet, I used a usb controller instead of plugging buttons in. When I connected the power supply to it and clicked the button, the status lights on the raspberry pi turned on. Since both the green and the red lights were on, I assumed it was booting, but the screen didn’t show anything. I fitted the ribbon cable in better, and that got the display to work. Then, I unplugged it and tried it again. Once I connected the power supply and hit the button this time, though, the lights did not turn on. I plugged the power supply directly into the pi, and it started booting and the display showed, but the picade hat was then unresponsive. Does anyone have any ideas for what happened? Maybe the hat is just defective.

Actually, I think I discovered the problem! I tried using a separate power supply instead of Apple’s MacBook power supply, and that seemed to fix the issue