Pirate Radio: one-line installer fails - Suite value changed

I’m trying to install the vlcradio code on my Pirate Radio, using the command given in the instructions:

curl https://get.pimoroni.com/vlcradio | bash

The script downloads correctly and starts running, but quickly stops with the dreaded “Repository changed its ‘Suite’ value from ‘testing’ to ‘stable’” error:

Checking environment…
Updating apt indexes…
…E: Repository ‘http://raspbian.raspberrypi.org/raspbian buster InRelease’ changed its ‘Suite’ value from ‘testing’ to ‘stable’
Apt failed to upgrade indexes!

… And the script exits.

Wisdom on the web has it that this can be fixed by using ‘apt’ commands instead of ‘apt-get’, or by adding --allow-releaseinfo-change to the apt-get command. But the web assumes I’m running my apt-get commands by hand, and I’m not - they’re embedded in a script. I will gladly edit that script as required, if someone can point out which apt-get commands in the script should have the --allow-releaseinfo-change option added to them. (There are about 10 in all).

Or can someone point me to a script that has already been fixed to work with buster’s updated status?


Kai

From the terminal try running
sudo apt-get update --allow-releaseinfo-change
Then try your bash script again.

If that doesn’t work run
sudo apt get update
That should get you a yes no prompt that you can say yes to. Any further apt-get update should then run without errors.

Thanks a lot, that worked. The installer script ran all the way to the end without encountering any errors. It did, however, print a warning at the very end:
“Warning: The VLC Radio installer does not work on this version of Raspbian. Check
https://github.com for additional info and support.” Do I need to worry about that?
It then prompted me to reboot, which I did.
Now what? The instructions say the VU meter should flash once when the radio is ready; I didn’t notice any flash. They also say to press FF or REV to start playback; I tried every button, and nothing happened.
Is there a service or daemon that should be running to implement the Internet Radio? Do I need to start it up manually?

Kai

That sounds like its a Buster issue. My Pirate radio hasn’t been updated to Buster. Its still running Jessie or Stretch, not sure which to be honest. Mine has been working just fine so I’ve left it as is for a long while.
Pimoroni may not have caught up to the Buster release and the changes its made to how things work etc.
My Vu meter flashes on boot up, same time I hear a pop in my speakers.
Mine would sometimes play right away on boot up, and sometimes it wouldn’t?. When it didn’t hitting FF or REV would usually start it up. That also made it change channels / streams on me sometimes which I found to be a bit of a pain. I went into raspi-config and set the wait for network option. Now it always starts up on its own and always on the channel I left it on when I shut ut down last. It takes a little longer to boot up but I’m fine with that.
You can get the earlier releases of Raspbian here, if you want to try it over again with stretch of Jessie.
http://downloads.raspberrypi.org/raspbian/images/

I better mention that Jessie and Stretch, will not work on a Pi 4. Only Buster has the correct Boot code for a Pi 4. If you are using a Pi Zero or any other Pi other than a Pi 4B its not an issue using an older version of Raspbian. For the most part anyway. Go back too far and you’ll run into the same issue with a Pi 3B+ or 3B. It won’t boot.