Radio Pirates

Premise : I have a perfectly running (2 years) Pirate Radio - The distro on SD is rhe Raspbian Jessie ( the fat one).

Now, I want to use the Raspbian lite version and for this reason I have flashed the today available Raspbian Buster lite image ( downloaded from Raspberry - I was unable to find the previous. releases ) on a new SD I have started the vlcradio installation.

At the end of the installation process I have the following. warning message :


The VLC Radio Installer
does not work on this version of Raspbian.
for additional information and support.

In short, I know that the problem, is not in your ( formidable - RogueM) script.

(*) see the two attached pictures.

Older versions of Raspbian can be found here
If it comes to you needing to go back to an earlier version.

Try running this from terminal
sudo apt-get update --allow-releaseinfo-change
Then try installing Pirate radio again. The issue may be that VLC radio hasn’t caught up with Buster yet.

1 Like

Thanks alphanumeric for the timely response and for information on how to find a previous distribution

My Pirate Radio is still running Jessie, or maybe Stretch? Its been running fine without issues for a while so I’ve just left it as is. There is no real advantage for me to update it to Buster so I haven’t bothered. I usually only redo it when it won’t work anymore from a power bump or something that has corrupted my SD card.
A lot of my headless setups are in the “don’t fix it if its not broken” category. I have 20 or so Pi’s on the go and only 3 or 4 are currently running Buster. My 4B and some 3B+'s. All the others are on Stretch or Jessie.

Following your suggestions I have downloaded, the 2018 latest Raspbian lite release , and the installed the vlcradio software without any problem.
Your conclusion about Buster is right.
Thank you again alphanumeric.

The Pi 4B was released before Buster was officially released by Debian. I don’t “think” any of the retailers had a working Raspbian release to test anything with on the Pi 4B? They had the hardware but not the OS. Only Buster will boot on a Pi 4B. I also think they were caught a bit unawares when The Pi Foundation said you can sell them now. Thats the impression I get anyway.
Raspbian Buster was still in testing when released which is why you have to run
sudo apt-get update --allow-releaseinfo-change to get apt-get update upgrade to work correctly.

Anyway, I’m sure Pimoroni will get caught up at some point. Enjoy your pirate radio, I use mine daily.

This is my Pirate Radio build, I recycled and old not working PC speaker setup. My Pirate Radio is where the sub woofer used to be.!AjOYwiwlwDtpgrJYICtv1AhtPRYFsw?e=Cgr4hH


I had the same issue with the Raspbian Buster lite image not working due to the vlc-nox missing. I tried to replace vlc-nox with vlc-bin but did not get it to work. Took me several hours to do internet research and try different things out, but did not succed. Finally I fell back to the simplest solution and revert to an old Raspbian version. The version @federico used produced an error, however, with Etcher under Windows. Here is the link to the image that finally did it:

After flashing the SD-card with the old version the one-line installer worked like a charm…



One thing with that link I posted is you pretty well have to go look in each folder to see what version it contains. Unless you have a really good memory and know when Jessie, Stretch etc were released. Or you could end up with an earlier release of Stretch etc. Work back from the folder with the newest date etc. Still nice that they are there if you need them.

I also have downloaded (from Windows OS ) on SD the Raspbian lite image using balenaEtcher installer without any problem.

About the Raspbian “buster” release version, it is not included in Pimoroni script function raspbian_check() ( see attachment) and for that reason we have a Warning message .

Seems like some other changes have been made to the latest PhatBeat version. At least in my instalation there was no playlist.m3u in the home/pi/.config/vlc folder - indeed, the vlc folder was missing completely. Nevertheless the radio had a default playlist which puzzled me as I did not know where it was located or how to change it. Just in case anyone else has the same problem her is what I did to fix it:

create folder “vlc” in “.config”:

mkdir /home/pi/.config/vlc

and then copy the default playlist to the new folder

cp /etc/vlcd/default.m3u /home/pi/.config/vlc/

then edit it with

sudo nano /home/pi/.config/vlc/default.m3u

and save it as playlist.m3u using CTRL-O

Hope, that helps…



You can find the file default.m3u ( Playlist) inside the /etc/vlcd directory

sudo nano /etc/vlcd/default.m3u
Is what I have in my cheat sheet for my Pirate radio setup. I don’t remeber exactly where I got it from, it was a thread here though.

To complete my previous say-

The info that we need can be found in the Pimoroni vlcd bash file(*) in usr/bin dir, where the conditions to make the /home/pi/.config/vlc dir are in the code. ( see the attachment).

(*) Pimorini/phatbeat/project/vlc-radio/vlcd/usr/bin/vlcd