PiratePython - Pirate Radio

Yesterday I got my little Pirate Radio. It is now up and working as an internet radio. But I have a question/observation.

In all the documentation it refers to the playlist being in /home/pi/.config/vlc/playlist.m3u.
After the initial install this file did not exist, but there was a playlist active. I could not find the file holding this playlist to edit it. It was only when I put the playlist in /boot that the playlist under .config appeared.
Was I missing something, or does the documentation need updating?

Yours, Plummet

Try sudo nano /etc/vlcd/default.m3u
Putting your own in /boot will replace the one I listed above with yours. On a clean install of pirate radio I believe its the one you want to edit.

I have this installed and it is working except I’m not having any luck logging in with the password p1r4t3 with no username.

Also where is the settings.txt file that is reference located?

Thanks

You can access the Pirate Radio from a web browser.

Enter the following address into the web browser:
http://raspberrypi:8080 or http://pi-ip-address:8080

• At the login prompt leave the username field empty, password is “raspberry”

My little Pirate Radio is now working happily. I have a playlist set up amd my wife and I can both control the channel it is playing through the vlc web interface.

So the next question is …

On the web interface you can see the ability to use the device as a media player. Can anyone tell me where it is expecting to see the audio files, or do I need a file similar to the playlist.3mu to point at the files, and what should it look like?

Ta in hope.

Plummet

My Pirate Radio doesn’t shutdown after push the off button.

When I push the button I only receive following output on my display:

[OK] - Stopped target Graphical Interface.
Stopping Pirathon Python Runner…
[OK] - Stopped target Sound Card.
[OK] - Stopped target System Time Synchronized.
[OK] - Stopped target Multi-User-System.
Stopping D-Bus System Message Bus…
Stopping Network Name Resolution…
[OK] - Stopped target Login Prompts.
Stopping Getty on ttyGS1…
Stopping Dropbear SSH Server…
Stopping Login Service…
Stopping Getty on tty1…
[OK] - Stopped target Timers.
[OK] - Stopped Daily Cleanup of Temporary Directories.
[OK] - Closed Load/Save RF Kill Switch Status /dev/rfkill Watch.
Stopping Save/Restore Sound Card State…
[OK] - Stopped Login Service.
[OK] - Stopped D-Bus System Message Bus.
Stopping Network Name Resolution…

Does anyone has the same issue or know a resolution? I’ve downloaded the latest version “pirateradio-v20180202.zip”.

Thanks a lot.

alphanumeric
The file /etc/vlcd/default.m3u is just the default file - used for only the initial install. Once you have a working system editing it makes no difference. So far the only way I have found of changing the playlist is putting a new version in /boot. I have been searching the file system for where the /boot version is moved, but without success.

Does anyone have a clue?

Plummet

OK, it was many moons ago when I tried to edit the one actually in use and add to it. Plus, I’ve only done it on the normal Pirate Radio curl Install. Lately I just put my small custom file in /boot and let it get copied to where ever it goes.

Yes - that is what I found. What I want to do is to upload music
to the radio, add it to the playlist, and reload the playlist
using the button on the html interface, without having to reboot
the radio.

Plummet

Did anyone figure out setting the start volume louder on boot?

Everything else working great!

Same here, could anyone tell me how to use the start volume parameter?

thanks

Did you found a solution?

loaded the latest v20180020 gets to the pirate pyhon info page asked to login the keyboard does not respond tried changing the log in details in setting not seeing the USB keyboard any ideas?

loaded the latest v20180020 gets to the pirate pyhon info page asked to login the keyboard does not respond tried changing the log in details in setting not seeing the USB keyboard any ideas?

I have a old Motorola if you want it to see if you can make it work,As a remote

I have a bag full of TV and Cable remotes to play with. I don’t think it was the remote that was the issue. More likely “my code” used to make use of the remote ;)

load the program gets to the pirate-radio
logo tried to log in but my keyboard not recognized tried different key board no joy any ideas?

Pi Zero? If yes it must be your USB HUB or adapter?

load the install noobs program no problem all works mouse and keyboard … notice when the program loads on startup i get the prompt failed to load kernel module tried different SD card same problem using win 10 also format the SD card with the prescribed format program… any ideas?

I think you may get better help if you start your own thread. It sounds like your not using the PiratePython image.
Personally, I don’t use NOOBS. I get Raspbian here,


An use etcher to image it to my SD Card.
Then I follow this to install Pirate Radio