Raspberry Pi Camera Issue


#1

I have a brand new version 2 Raspberry Pi camera board, connected to a brand new Raspberry Pi 3B+ with the included cable to the CSI. The camera is mounted to a ninja difusser that is then mounted to Pibow case with the long extender bolts

.
I was very careful not to overtighten the mounting screws etc. Only just enough pressure to hold it in place. The screws are the ones used in this holder.https://shop.pimoroni.com/products/raspberry-pi-camera-mount

However, I’m noticing artifacts, long thin black bars scattered in the camera video, and weird colors splotches showing up in the video feed if I pick the case up or just move it. It doesn’t do it every time, but often enough to make me think I have an issue. I have two version one cameras I move around quit a bit and have never seen this happen with those.

I’ve reseated the cable, and swapped the cable. And unbolted the camera and it still does it? Only thing I haven’t done is swap in another camera. It’s on my list as the next step if need be. It’s a bit of work to take everything apart.


#2

I think it might be a heat issue? It’s working fine now, only just turned it on. When it was acting up it was in the window in direct sunlight, and had been for several hours. It’s a bit overcast to day so I’ll just leave it running all day and see if my issue reappears.


#3

What ever issue I have or had, seems to be gone? I let it run all day yesterday, then tapped, bumped and moved it around and no streaks or splotches. No really hot sun shining on it but everything was well warmed up.
I was also having and issue with motion eye on this hardware, Pi 3B+ running Motion Eye OS locking up? After switching from my Lexar Micro SD cards to a Sandisk its been fine with no lockups or freezes. Two full days of running, it hardly ever went a full day with out locking up. So I guess this is solved for now.


#4

Sorry I appear to have missed this entire thread- but it looks like it fixed itself anyway. Has the problem come back at all?


#5

I’m occasionally loosing the feed, but the artifacts etc seems to have stopped? I can’t reproduce the issue. We haven’t had another really hot day like when it was acting up though. And likely won’t until next summer, lol. When it was acting up it was in the window in very hot direct sunlight.
I have three motion eye setups, the other two are Pi 3B’s (not +'s) and version 1 cameras. They run fine 24/7 with no issues.
This one is a Pi3B+ with a version 2 camera. Its all new hardware. But it has issues with dropping the feed. Has from day one actually. I changed some settings and it recovers most times. Sometimes I have to power cycle it to get it working again. I “think” its an issue with Motion Eye and a Pi3B+ but got nada when I posted the issue on his GitHub issues page.
At some point I’m likely going to swap the Pi 3B+ for a 3B, if I can find a 3B for sale some place. Motion Eye won’t connect on the 5G WIFI anyway. I couldn’t get it to work. Works fine in Raspbian though.
Anyway, to make a long story short I think the artifacts issue is gone. Maybe it was the ribbon cable connection or something?


Motioneyesos suction camera holder
#6

@gadgetoid Phil does Pimoroni still sell the 3B (not the +)?


#7

I don’t believe so- we normally drop the old versions like a rock and focus on the new :(


#8

No problem, I can understand that. Adafruit is still selling them so I could get one there if need be. Won’t be for a while anyway. Christmas maybe. And I have a fellow Pi enthusiast that isn’t too far down the road that would likely trade me a 3B for 3B+. It would be a free upgrade for him.


#9

I think there is something wrong with that Pi 3B+? I put the newest Raspbian on it, on a brand new Micro SD card I bought at The Source and it totally locked up some time this morning. Had been running fine for 12+ hours.
It updated fine etc. I then opened a browser to a stream from one of my other Motion Eye cameras and just left it running all night. Activity LED was flashing all night and this morning. Just got back from my morning walk and turned on the monitor and its totally frozen. Can’t move the cursor and the image on screen is frozen in time. Power and Activity LED are both on steady.
I’ve had fatal IO error messages on this Pi in the past, usually when doing a sudo apt-get upgrade. Figured it was the Lexar SD cards. I don’t remeber getting the same error with a Sandisk card, which is what is in it now. When its failed in the past running Motion Eye its also been a total lockup. Only way out is to power cycle it.
I bought that Pi on August 30th so I’m thinking its past the return date. I’ve had it almost 50 days.
Maybe I’ll get out my isopropyl alcohol and try cleaning the Micro SD card connector contacts?


#10

Swapped the 3B+ for one of the 3B’s in my other Motion Eye cameras. Kept the original case, power supply, camera and Micro SD card that the 3B+ was using. Put it in the same location as the 3B+ was and will let it run 24/7 and see what happens…
Also going to try booting / running Raspbian on the suspect 3B+ from a USB thumb drive. Will let run 24/7 also just to see if it locks up again.


#11

Both Pi’s are still running this AM. The 3B+ had already locked up by this time yesterday.
My original camera issue has not reappeared so thats good.
Still not exactly sure what’s up with that Pi 3B+ though? I’m going to leave it running all day and see what happens. If it doesn’t glitch I’ll probably reimage one of my not in use Micro SD cards and swap that in in place of the thumb dive its booted from now. Running Raspbian like it is now. Then wait and see what happens.

@gadgetoid I’m doing the @ because I have to edit, it won’t let me do more than 3 posts in a row.
It looks like my issue is with Motion-Eye on my 3B**+** or I have a dud 3B+. I just put the 3B+ back in its original configuration with the V2 camera. I got several stream failures / breaks or pauses. I get a black screen with a camera icon with the do not enter circle bar thing on it. No Video. Then in a couple of seconds it comes back. That 3B+ has been doing it from day one. Even with a version 1 camera so its not the camera. Its the CSI interface, something else on the Pi, or the Motion Eye 3B+ combo? Its not overheating thats the issue. Its in a cool place at the moment, I have another 3B+ but its buried deep in another project.
I’ll swap them out some time tomorrow.