Reset after 20 seconds when PiHat attached

Hi - last night I assembled a brand new 10" Picade but haven’t had much luck getting it to run. My Pi4B runs fine connected to the cab and everything works as it should until I connect the PiHat. Then it boots and resets every 20 seconds or so. If I connect the power to the Pi with the hat attached it will run fine but then the controls aren’t recognised. I’m tearing my hair out here! Does anybody have any ideas?

Is the XHAT properly seated on the Pi? Do you get anything on the screen during the startup, and what happens on the screen when it resets?

Thanks for your response! I believe it’s properly seated, yes. Retropie starts to boot then it just resets and goes back to the beginning of the boot, on an endless loop. The screen works as it should.

I’ve tried different SD images and removing the various cables one by one - it makes no difference.

Ok solved. 4th time burning an image worked a charm. Thanks mironc for trying to help - really appreciated!