Run out of ideas why I have no sound


#1

So I bought the 8inch PiCade kit a few weeks ago and had it all up and running fine.

Then I bought the 12.1 inch screen and now no longer have ANY sound coming through the speakers. I’ve dropped in on a few other threads on the forum regarding this issue but so far have had zero response so thought I’d ask again this way.

Since fitting the screen, I’ve tried re-installing RetroPie from version 3.0 to version 3.1 in the hope that might cure it with no such luck. Checked the wire connections are secure from the speaker volume buttons to the PiCade controller board (all tight) and that the audio cable is plugged in properly between the Pi and the controller board (it is).

Not sure how relevant this is but I’ve tried plugging my earphones into the headphone jack on the controller board and can hear no sound from there either.

The ONLY way I can get ANY sound is either plugging my earphones directly into the Pi or plugging my tv directly into the PI via the HDMI socket.

Has anyone else who purchased the 12.1 inch screen had any issues like this or knows of anything I could try to fix it?

Any help regarding this issue would be mega appreciated as I’ve come to a stand-still now with this project.


#2

Obviously sound is routed to HDMI.
To force it to the analog output (the headphone jack on the Pi) run
’sudo raspi-config’ and select the audio config option in the advanced menu.
See https://www.raspberrypi.org/documentation/configuration/audio-config.md for details.
You can also use this command directly in a terminal:
amixer cset numid=3 1
Raspi-config uses the same command behind the scenes.
Hope this helps.


#3

I had to go into the settings for retropie and setup audio through there (which effectively launches the same interface that tvoverbeek is talking about), if this is set to ‘auto’ once you get in, that will hopefully be your problem. change it to output over the 3.5mm jack instead.


#4

Strangely it did turn out to be the Audio options in RetroPie itself. I say strangely because I never had to change anything when I first built the PiCade with the 8inch screen because everything just worked and it was the first thing I tried when I upgraded the screen. That it refused to work then AND refused to work when I upgraded to RetroPie 3.1 made me believe that it wasn’t that simple. Oddly after I left it for an hour or so, I came back, tried again and it worked straight away.

But thanks to all who replied anyway.

Just one odd question…

Does the 12.1 inch screen come with a protective peel off plastic cover? Reason I ask is that when it’s running the picture does look slightly dark (certainly darker than the 8inch). I’ve looked at it and to me it does kind of look like there’s a peel off but I’m really not sure and I don’t want to break anything.


#5

I havent installed mine yet. Just took it out the box and would definately say it has a screen protector on it (standard for most screens).

Looks tricky to get off though.


#6

I was thinking that screen protectors came as standard too. I got to the point where I actually stripped the PiCade down and removed the screen again to have a good look and there does seem to be a thin layer of something on there. When I tried to get my nail under it tho, it felt harder than the normal peel off stuff you usually find which made me think maybe it was just part of the screen itself and I didn’t want to chance it…


#7

AUDIO
The audio setting thing is odd actually. I did a complete fresh install and the audio was working, then after a load of reboots and dicking around to try and get the screen working properly, the audio just suddenly stopped working (I wasn’t making any changes with regard to audio specifically). Then I used that menu and hey presto, audio restored. There is obviously something odd going on somewhere, but no idea what it is. Will wait and see if audio vanishes again over time.

SCREEN
I don’t remember peeling a screen protector off my 12.1" screen, but it doesn’t seem particularly dull… although now I will be thinking about it every time I play!


#8

FYI:

    jonNinja     
          
    
      That is the touch overlay - it's best not to remove it!

#9

I thought it didnt look like it should be removed. Thanks for the update.


#10

The RetroPie audio settings should save also, as they do a alsactl store after configuring. Note that the menu always defaults to the first option, so it doesn’t actually tell you what the current audio setting is.

Regarding loss of audio again. maybe some other change was set, or at some point the config was lost. Things like video mode group and options like hdmi_drive affect whether the audio defaults to HDMI or jack etc.

On my Kickstarter Picade Maxi, as it uses a DMT mode by default, it doesn’t do HDMI audio, so I force HDMI audio by doing hdmi_drive=2 (As I have the speakers connected to the driver board on that Picade)


#11

I noticed a loss of audio after I updated the binaries via the RetroPie menu.

Any ideas why?

Cheers,

Mark R.