(SOLVED) Pirate Radio Forward/Backward Buttons not working


#1

Hi guys!

I received my pirate radio, (hopefully) sucessfully assembled it & ran the script. I also edited my playlist.

After the first reboot the radio & the VU meter powered up and I could listen to music. The volume up & down, the pause & the power off button (the one on top) work perfectly fine, but when I try to change the radio station with the forward or backward button (the 1st and the 3rd) the radio kinda crashes. No vumeter lights, no music, when attached via hdmi to a screen the screen turns black…

Ive tried to solder it but my soldering skills are pretty bad so i ended up using the solderless hammer connectors …

Any ideas?

Thank you!!


#2

Did you enter more than one station in your playlist? And how did you edit it?


#3

Thanks for the immediate response!!

I just did
sudo nano /home/pi/.config/vlc/playlist.m3u

and edited the file.

I copy pasted the urls pressed enter and copied the next one… see the picture taken from phone ive attached


#4

I can’t recall exactly - it’s been a while since I set up a bunch of radio stations - but I think VLC has trouble with .m3u files, which are playlists that can contain one or more steams (just like the local one). Grab the m3u files on your Pi with wget or a computer, and get the stream URLs from them.

For stream1.energy.at:8000/vie.m3u it looks like just dropping the “.m3u” might suffice.


#5

Thanks, i got 3 working urls now…

After a sudo reboot, the radio starts with the radio station on the first row from the playlist.m3u

When I push the FF button crash… the CLI is still there, just no vumeter and no sound…

If I try it with a different station on the first place, it works till I press the FF button again…

Could it be a hardware issue? How to check if the buttons are working?


#6

Same thing happens to me occasionally, I just assumed the live stream from that station wasn’t working for some reason. I can usually just go up or down one more station and it works.


#7

How does your playlist.m3u look like?

Like mine? With one url followed by return and on the next line the next url?

After pressing the forward (or back) button I have to disconnect the rpi from power & plug it in again to reboot… no other button works…

So rly no problem with volume up/down or pause.

Maybe because I first tried to install the airplay script? Any idea how to test the button? Like a logfile?


#8

Mine are all actual IP addresses like this, https://198.27.70.26:10042


#9

I should have mentioned, I have python code to let me do it all via an IR remote control. I almost never use the physical buttons on the pHat Beat. Except when the remote quits working, its still a work in progress. Then I have to reach into my case (a wooden sub woofer box) and press the power button to shut it down. Some times everything works great. Some times one channel just doesn’t work, no sound and nothing on the VU meter. Occasionally the remote just stops working completely. I have no idea why though? Pushing the power button to do a shut down still works. The other buttons are very hard to get access too. That will all change once my latest Pimoroni order arrives. I’ll be wiring up some arcade buttons to do what the pHat Beat buttons do. All on top of my speaker box for easy access.


#10

thank you very much for your reply.

Finally found it!

It was DNS issue here for me…
your actual ip adress post pointed me in the right direction…

tried to ping google and got a couldnt resolve host… echo “nameserver 10.0.0.138” | sudo tee -a /etc/resolv.conf and then tried the button again and it switched smoothly to the next station. Just made it permanet with supersede domain-name-servers 8.8.8.8, 8.8.4.4, in dhclient.conf and it works!! :-)

Thank you!!!
Your project sounds interesting. You could upload a pic for illustration purpose :P

Okay, next question:

can i also install the airplay script, so that I can use the pirate radio as internet radio AND audio output for my iphone?


#11

Ooooh, remote control. I would be interested in hearing how that could be put together!


#12

My order should arrive any day now. Once that happens and I start wiring up the buttons, I’ll post picks. If you look at the pHat Beat you’ll see numbers bedside the buttons. Those are the GPIO used by that button. All you have to do is wire your own switch up to those GPIO. Normally open momentary switches are what you want. That’s why I picked arcade buttons. Plus they work great for mounting in a wooden case. ;)

Getting a remote control to work is a bit trickier. Originally I wanted to use a wireless mini media keyboard, but couldn’t get any usable codes out of it. Use a media keyboard with your pHat Beat, can it be done?
I have a FLIRC, https://www.flirc.tv/ It can learn just about any IR remotes codes. As far as the Pi goes it thinks its a USB media keyboard. So I switched to that and tried a few different remotes. Some work better than others. My code works but it needs refinement. It glitches now and then and just stops working. That Pi is headless so I don’t know what happened? My plan is to add my code to the main py file so its all running from the one file. Haven’t found the ambition to actually do it yet though. I think i’ll have a go though once I get working on it again and have my buttons all wired up and uable, as backup.


#13

Just finished wiring everything up, pictures here, https://1drv.ms/f/s!AjOYwiwlwDtpgrJY6ORLsK5AVpwNuw Will do a write up and put it in the Project section latter on today. The case is the subwoofer box from a set of Logitech R20 speakers. Ditched the subwoofer but used the speakers. I used a Proto pHat to get access to the GPIO.

http://forums.pimoroni.com/t/my-pirate-radio-build/5620