UF2 file won't load and returns as empty RP1-RP2

I have a problem loading any UF2 on my Pico. Clue is that when I plug it in, without pressing reset, it always comes up as RP1-RP2 empty drive.
When I load any known to be working UF2 file, you can see windows xferrring data. Window closes but instead of returning and running code,it opens again as an RP1-RP2 empty drive.
GroundHog day!
Before getting down to look for short circuits on reset, etc.
Has anyone had this with a pico board, due to messing with flash memory etc?
Out of interest, this was bought as a presoldered board.

Have you tried running flash_nuke.uf2 then in REPL running:

import storage

These two steps should bring your Pico back to factory.


Hi BruceB,

One of the first UF2’s I ran was flash_nuke_uf2.

But, like every other uf2, it merely reverts to RP1-RP2 with no pressing of bootselect button.

On the hardware side, I wondered if the TP6 pin was being held low but this tests ok and the button is not s/c either. Which is why I wondered about the flash, crashing.

I’ll try another tack. Thanks for the suggestion anyway.


Further to my last message.

I have just tried MMbasic interpreter, Adafruit’s Circuit Python and a compiled file from Arduino IDE. All apparently load, but no run.

I’m glad the Pico is not too expensive to lose. If I had zapped it and bricked it completely, I would have nil response and less frustratation than a reset usb drive.

Windows says it is a 127Mb space.I can load files to it and fill it up and delete them. However, if you either disconnect it OR load it with a working UF2 file, it disappears momentarily and then comes back empty, apart from the HTML and text file from Raspberry PI.

Most perplexing.



Your results remind me of back in CircuitPython 6.2.0 days. The OS was not waiting long enough For the Flash Memory and RPi-RP2 would pop up 90% of the time. If you have tried any of the Circuit Python 7.0.0 or newer versions they have this bug fixed.

I think it may be time to get another Raspberry Pi Nano or one of the AdFruit RP2040 variants. I would point you to the QT Py RP2040, ItsyBitsy RP2040 or the Feather RP2040 because they come with excellent technical support. They also have a bunch of RAM and a NeoPixel tri-color LED on the board. They are worth the $10 to $12 price.



Thanks for the suggestions.I will look at some of these devices.

However, this is the first time I have had this, or any fault, amongst the many picos I have purchased.

I will put it aside and look at it sometime in the future.

I think without the insider knowledge of how to rewrite the factory code, if in fact, it is a software problem, I cannot go much further.As the TP6 pin showed no sign of contact with eth, it must be a fault somewhere inside the RP2040 architecture.



I have been told that the Boot Code in the RP2040 is burned in and can’t be updated, so says AdaFruit support Admin.

There may be a bad solder joint under the RP2040 chip. Another thing you probably can’t fix, unless you have a solder reflow system.

Considering the price, bricking one of these is a shame, but not a sin. Good luck.



Interesting, thank you for the feed back and research.

I think we can draw a line under this one.