Zero Lipo software causes Failed to Authenticate error


Installing the clean shutdown software using curl | bash causes a “Failed to authenticate” error on the Pi when booting/rebooting. Entering the correct password does not work.

The only way to recover this situation is to re-flash Raspbian onto the SD card. I am using the July 2017 version of Raspbian and a Pi Zero v1.3.

Very annoyed - I have lost all of my previous installed configurations for I2S MEMS microphone, OLED display etc…


I can’t envision any success or failure case where our installers would mess with your login credentials. That doesn’t mean it didn’t happen, but I’d be very surprised if this wasn’t just coincidence. I’ve brought it to the attention of @RogueM anyway.


yes, there is absolutely nothing in that script that messes with any relevant part of the system, for example users groups and users.

In the future, if this happens - not with our scripts, I mean generally, try to check that your keyboard is working and set to the correct layout, by booting to level 1 (Single-user mode). It could well have been the problem.

Also, never wipe off a SD before seeking help, make a backup of it or set it aside until some clarifications or suggestions have been made. I can certainly understand the frustration of losing a finely-tuned system :/


Many thanks for your responses.

Before making my original post, I checked to see if I could replicate the problem. I tried twice with a newly installed version of Raspbian that successfully booted to the desktop. Both times, I got the “Failed to authenticate” dialogue window after installing the script.

I put this down to more than coincidence, hence I made my post.

I have never seen this dialogue window when booting the the Raspbian desktop before. The dialogue window appears before any keyboard input is made, and it shouldn’t be there in the first place. I would be very surprised if this was a keyboard problem.

Maybe it is coincidence, and I will try with an alternative SD card in case the problem lies there, for some reason (although it appears to work OK with a freshly installed version of Raspbian).

I will post back here if I discover something new, in case it helps someone else in the future.


I am witnessing the same behaviour as hystrix.
Additional observation - the identical Authentification Error on Boot only occurs when using external USB Power Supply. Booting using ZeroLipo and Lipo cell works fine.


Interestingly, I saw this issue on my son’s pi, after he ran an update, about three weeks ago. In his case, nothing to do with the Zero Lipo software, because we don’t use that on that pi, but the boot issue manifesting itself as you describe. I think in our case we also had to re-flash the SD card with a new image, but we did backup first.
Strangely, although we updated several of the pis (we have a few!) in the house at around the same time, it was only an issue on his. The only thing I can think of that differentiates his pi from the others is that his is a pi 2.


I wonder if it’s a power instability thing? Interesting. Filesystem corruption is the only thing I can think of that would cause it to fail in some cases but not others.


Hi, a complete beginner here, but I have the same issue with ‘Failed to Authenticate’ after running the one line installer (curl | bash), in full raspbian and lite.

However, I did it another time after running the clean shutdown installer first (curl | bash), before cancelling out of it when it asked for a pin as i wasn’t sure, and it seemed to run ok then. On that occasion I thought I’d misread things and shouldn’t have installed clean shutdown beforehand.

Can you confirm that clean shutdown should be installed first, setting the pin as BCM4, then install the zerolipo oneliner? I have it soldered on as per the Tiny4WD setup.




The Zero LiPo installer should install cleanshutdown as part of its process, you shouldn’t need to install them separately.


Thanks. I’m reluctant to try again and have to flash again. On one attempt the zero lipo one liner was the first thing I installed and still got ‘Failed to Authenticate’. Any ideas why this keeps happening? Or, seeing as it worked once, should I just run clean shutdown first, select BCM4 and then run zero lipo? I know I can just go ahead and try but don’t want to mess with my tiny 4wd too much, had a hard time getting a controller to work on it.


I don’t know why the “Failed To Authenticate” problem happens, but it’s most likely a result of a corrupt flash, a flaky SD card, or a poor power supply causing the SD card to appear corrupt/flaky. I suspect the Zero LiPo software being installed is more a case of correlation, rather than causation. Although it could be powering from the Zero LiPo itself that’s causing SD card issues. It’ll be tricky to pin down, I suspect.



Just to confirm, it’s happened after few fresh flashes of both Raspbian Full & Lite, with the ‘official’ power supply and (I think) on two different cards.


This is really bizarre. I wonder what causes this error. I wonder if @hystrix ever got up and running?

@Gruntplace presumably you’re using a Zero W? What SD card brand/size/class etc are you using? Could you snap a picture of them?

On a freshly installed image you should try running; sudo apt-get update and then sudo apt-get upgrade to see if it has a similar effect.

The installer isn’t doing anything untoward, but it is shifting a lot of data- updating apt, installing various packages, etc- and that will very quickly cause any issues with SD cards or maybe even the Pi itself to manifest.

I’d love to know why this happens.


Hi, here’s a pic, both are the same and the pre-installed noobs ones (one from yourselves and the other from pihut).
Is it worth trying the cleanshutdown and selecting BCM 4 first, and then zero lipo just to see if it works, or would it be a waste of time?
I’ll try the second card again as I’m going to reflash it anyway as I was using it on the pirate radio spotify streamer which I can’t get working.


Sorry, and yes its a new pi zero W with the zerolipo soldered on and explorerphat on top (the tiny4wd setup) using the bluedot app on android as the controller (couldnt get PS3 controller to work).
Although on one attempt, zero lipo was the first thing i installed as i expected the issue.


OK, so tried the other card, formatted and fresh latest raspbian lite img, ran update, upgrade then zerolipo and same thing happened.


D’oh. Can you run the update/upgrade on a fresh install, but don’t install Zero LiPo? I’m trying to identify if it’s something unique to our script that’s causing the issue, or just general thrashing of the SD card from installers.


Hi, i did that first and it all went through without any errors. I’ve done it again as had to flash card anyway. Card formatted was overwrite format rather than quick format. Only other thing done was to connect to wifi through raspi-config.
Update and upgrade went through fine. Did not run zerolipo or cleanshutdown afterwards. No problem logging in after reboot.


Right, that’s a start. Thank you!

Let’s see if we can pull apart what Zero LiPo installs and where it’s stumbling.

On this image, start with cloning the repo, then reboot:

git clone
sudo reboot


Thanks. Sorry, I had to go out but will do that this evening. I’m a complete beginner so you might have to use baby talk. So I just run the one liner…

git clone

… and then just reboot with sudo reboot. I’ll photo the running script again in case you want to see it.