Graphics on Pico Display - Tutorial

Help to get you started with your Pico Display:
Pimoroni Pico Display Workout : 3 Steps - Instructables


I should have mine some time this week. Looking forward to having some fun with.
Thanks for the link and the time you put in doing it. =)

Thanx for the tutorial, a fine starting point! Worked like a charm. Especially the ‘scrolling-sine-text’ is wonderfull!

Thank you. Nice to know when people find things useful.

Ditto to what @Bouffski said. Just ran it on mine. It will be my go to code for stuff I want to try. I wish I had your skills. well done. =)

Thank you. Very glad to share.

Very useful, thanks.

Hi Tony…tried loading your code into Thonny and running it. It starts and then said “Start” in the shell so I hit ENTER on my PC…something then happens on my Pico Display, I think. … My problem is that when I power up my Pico with the Display Pack plugged into my Omnibus Pack, I immediately get a graphic of, what looks like a depiction of Saturn with its ring(s) and when I run your code your graphics look like they appear behind the planet graphics in the lower Right Hand corner but just seem to be a series of hyphens running at an diagonal up the screen. Anyone any ideas?? BTW…the Shell does not report any errors with your code.

Did you save a python file to the PICO previously? If you did it will run as soon as the PICO boots up. And may interfere with any code you try to run from an IDE.
My PICO Display Pack is also plugged into an Omnibus. I currently have the Pimoroni demo running on mine on boot up. I did a save as and saved it to the PICO.
I haven’t tried to remove it yet, might have to go and see how that’s done?
Reflashing the uf2 file should do it?

To delete from Thonny try to save to the Pico. This shows what is stored. Right click the file and pick delete.

You beat me too it. Reflashing the uf2 file didn’t erase it, and I couldn’t see it in file explorer. I finally went to Thonny, load file, from PICO, and in the window that opened right clicked and selected delete. It didn’t autostart on a reboot of the PICO so I assume its now gone.

Flash_nuke.uf2 would have cleared the lot. Followed by reinstalling the Pimoroni-pico…uf2 and you are ready for a clean restart.

Maybe I did it wrong then? I held the Boot Select button down and plugged it in. Then dragged and dropped the Pimoroni uf2 onto it. It rebooted on its own and the demo was still running / there?

Thats’s OK but it can leave files in place which you cannot normally see. NUKE removes the lot and then you install the UF2 you want to an empty Pico.

I think its main use is when moving from C++, which I’ve not tried yet. It appears to be even more complicated than MicroPython.

Ah ok l’m with you now.

It is quite handy when switching. I drop my compiled C++ uf2 whilst in boot-mode and it now runs my C++ code. If I want to switch back to Python I just drop my Pimoroni micropython uf2 whilst in boot-mode and it immediately runs the python code that was there.

I think you will soon run out of room.

I’ve already hit the memory limit with screen corruption and loss of communication between PC and Pico with a 300+ line graphics program. Not sure the garbage collection routines are working that well.

gc – control the garbage collector — MicroPython 1.9 documentation

Tony, where do I find this Flash_nuke.uf2 program. I have tried just about everything else which people have suggested…even sent emails to Pimoroni but so far nothing works, and no reply or suggestions from Pimoroni themselves, which is a bit disappointing.

@Airborne2 Go here, scroll down to the tabs and select “About Raspberry Pi Pico”. Scroll down again and there’s a download button in the section titled “Utilities” under the subheading “Resetting flash memory”.

even sent emails to Pimoroni but so far nothing works, and no reply or suggestions from Pimoroni themselves, which is a bit disappointing

That’s not like them, did you use the email address?

It is really quick. Hope it fixes your problem.