How-to: Picade 12" Screen + HAT + Single Power Source + On/Off Buttons!


#41

Cheers Paul!

Getting there, my DIY skills are definitely not up to scratch. Hard to keep the black powdercoat intact when drilling?

How do you know which of the dc panel socket terminals are positive and negative?

Best regards!


#42

Sigh! @Paulcheffus Luis @Dyltone

Bit of a fail I’m afraid guys. Finally finished my build, excited! Plug in and…dead! Nothing! No power at all. Don’t know what I’m done wrong. Power pack light is on all cables plugged in, even tried plugging raspberry pi plug direct into atxraspi. I do at least get a quick red light flash on the atxraspi board (I think it’s next to shutdown) but no backlight on mom button.

The only thing I wasn’t brave enough to do was to solder the wires to the DC in or mom button they are attached with crimped spade connectors but they are pretty tight. Do you think they have to be soldered? Also tried to copy everyone’s pictures pretty sure the wires are all in the right place but let me know if you see anything. Have attached a picture, any help would be great!

Thanks in advance


#43

Hi

Do you have a multimeter?

If so disconnect the power supply and measure the voltage coming out it should be around 12v.

Once that has been established disconnect everything except the 12v to 5v converter. Check what voltage you get out of the converter should be around 5v.

Let me know how you get on and we can take it from there.

Cheers

Paul


#44

Basically what Paul said… without the multimeter, I’m afraid there isn’t much we can troubleshoot, but I will say this.

The cord supplying 12V the CTP has 2 configurations, one is inside ground and the other is outside ground, depending on which two of the three connectors you chose. This configuration needs to match the same as your 12v 2.5mm power supply.

The power supply may be labeled as to which is the ground (inside/outside), but I think most are inside hot, outside ground. Make sure you have configured your internal connector to the same configuration.

Good luck. Keep us in the loop.


#45

Hi guys,

Thanks for the support @Paulcheffus @Dyltone , really appreciate it! Maybe I should have started with something a little more simple for my first electronics project :)!!

Ok so buying a multimeter today, guess it’s a gd thing to start building up my electronics toolkit if I plan on doing more projects no idea how to use one though :)! (already got a soldering iron, which I also need practice with!). Silly question when I’m testing the 12v barrel jack, and in general when usually the multimeter, should the plug be switched on at the wall? Don’t want to electrocute myself ;)! I think I understand how to test the DC power supply but if that is ok how would I use the multimeter to test the CPT as the 5v output is a micro USB connector?

Dyltone thanks for the advice re 12v power supply, mines an outside ground so pretty sure my DC panel connector is wired up right as the positive cables are attached to the inside connector. Only question is my negative attached to the right connector? The empty pin seems to have an ‘s/c’ written on it?

The weird thing is the 12" monitor is attached directly to the 12v in through the DC panel connector (I.e. Doesn’t go through the CPT) and there doesn’t seem to be any power going to that either which would suggest no power is entering the picade, so either the DC power pack is faulty (unlikely) or my crimp connectors are not making proper connections (possible :)) wondering if soldering to the DC panel connector and mom switch would be better? Just concerned that seems pretty permanent! The other thing that would support this is when I bypass the CPT and plug an RPi plug directly into the ATXraspi I do seem to get some power as a red light flashes on the pcb but again no backlight on mom switch and pushing the button does nothing which could indicate the crimp connectors.

The only other thing i was wondering was whether I damaged the ATXraspi when soldering the USB port and jumper pins. It was my first experience of soldering and I wasn’t very good, although the solders look ok I think the iron was too hot as slightly scorched the pcb around the connections. Don’t think I caused any shorts but you never know.

Any thoughts? Will test the DC power a little later if you can let me know about whether power should be on/off at the wall and how to test CPT micro USB I can start there :)!

Cheers!


#46

Hi

It could easily be the crimping of the connectors that is an issue here hence my suggestion of using the multimeter.

The power should be on at the wall but only connect your multimeter to the DC output DO NOT go anywhere near the mains side. The multimeter should be set to the the DC voltage range when performing these tests.

If you put the red probe into the end hole of the barrel and the black probe on the out side of the barrel the meter should show around 12 if you get -12 then the centre of the plug is negative.

My CPT was supplied as two separate wires but to test yours you can plug it in to the ATXRasPi (disconnect the Pi) and you should be able to put the multimeter probes on the PCB below the USB socket marked + and - highlighted in yellow in the image below

I soldered my connections to the DC socket and switch. I also soldered the crimps to the wires that go into the molex KK connectors for the ATXRaspi as I used a pair of pliers to attach these and they don’t do as good a job as the correct crimping tool.

I’ll check the connections to my socket shortly when I get home for dinner and let you know which ones I have connected.

EDIT : Checked the connections on my socket and there is no connection to the one marked SC with a lightening symbol between the letters so it would appear you have used the correct connections. Can you also photograph the rear of the ATXRasPi PCB so we can see your soldering as it might be a dry joint.

Cheers

Paul


#47

Hi Guys!,

Right here are my findings! 12v power pack working fine, also 12v coming through to the other side of the DC panel socket. Plugged the USB coming out of the CPT into a set of Bluetooth headphones and they started charging, so power coming out of the CPT. Although weirdly not getting any readings from my DC cable coming out of the DC panel connector that goes into the screen which is weird as they are in the same crimp as the CPT which is working. When measuring the + & - on the ATXraspi as shown in your picture I’m getting 5v. However button still not turning pi on. Is there a way to measure power coming out of the ATXraspi? Or could the mom button be at fault?

I’ve attached a picture of the solders of the ATXraspi, don’t judge me! This was my first attempt at soldering and I was rubbish, you’ll see the scorch marks, I think the iron was too hot. Could I have damaged the PCB?


#48

Hi

Your soldering looks fine and it is quite difficult though not impossible to damage a PCB through too much heat.

If the cpt has power but the screen doesn’t then it could be the cable to the screen that has the fault.

With the switch have you connected the switch to the correct points on the ATXRaspi? When looking at the top of the board the switch should be connected to the two holes on the left at the top edge of the PCB. On the switch are these two connected to the switch terminals not the switch led terminals?

It might also be worth removing the connections to the raspberry Pi GPIO from the ATXRaspi

Cheers

Paul


#49

Hi Paul,

Yeah, pretty sure I’ve got the button connected properly, on the switch itself I’ve got the Negative connected to C1 and positive connected to NO1 then the two led connections either side. Then on the ATXraspi the connections on the top of the board are switch -, switch +, led -, led +. Also got the boot ok and shutdown cables connected to the top two pins on the side in that order. I followed this of the ATXraspi page

Also here’s a picture of my wiring out of the picade

When you look at the underside of the ATXraspi you see the + and two -'s underneath where the USB sits? Would you expect to get a 5v reading from here without pushing the switch? I tried and I got nothing.

Cheers!


#50

Sorry,

First pic didn’t upload, here’s the schematic I followed for wiring, only difference is I’m using USB in and USB out


#51

Hi

Without pressing the button I wouldn’t expect any voltage on the output USB connector.

Can you try removing the connectors to the GPIO and see if that makes a difference. Also short the two switch terminals to see if that switches it on to check if the switch is faulty.

Cheers

Paul


#52

Cheers Paul,

Do you mean remove the boot ok and shutdown pins from the pi GPIO?

Sorry next newbie question how do I short the two switch pins on the ATXraspi?

Thanks for all your help!


#53

Hi

Yes remove the boot ok and shutdown.

Remove the switch connections from the ATXRaspi and using the blade of a screwdriver short the two pins that you have removed the switch wires from.

One other thing I’ve just noticed. Where you have bolted the ATXRaspi to the case you have used all four mounting holes. I only used two as the one nearest the switch connection could possibly cause a short one the holes that are in that corner. Might be worth removing that mounting I case it’s shorting on the rear of the PCB.

I’m beginning to think it might be the crimps as they look quite large and the pins on the switch are small. I would remove the crimps and solder the connections.

Cheers

Paul


#54

Hi @Paulcheffus,

Thanks for the guidance, sorry for delay, been out this morning! So some progress!! I did wonder whether screwing the ATX board down fully was creating issues so I took it off last night and tried again with the button…no difference.

However, tried pulling the button wires and GPIO wires off the ATX today (although left the led ones on) and shorter the +/- pin on the ATX and the pi and Picade board came to life!!! (Led on button also came on. However still no power to the screen so hard to turn off at the wall.

So now all working except button to turn on and off and the power to the screen controller board. Is there anyway I check to see whether the button on off is def faulty (or whether it’s the crimps) and second can I test the screen DC wire in any way (still not sure which of the cables are +&- on that wire but if it was conductin power surely I would get a reading either way using the multimeter?

Cheers!


#55

So I guess next question is do i solder all the connections? I guess I would want to make sure the screen cable is wired correctly and that it works before doing so?

Cheers!


#56

Another update! Decided to wire up the screen controller cable the other way around black & white cable as neg and black cable as pos. Now I get a reading from the cable with the inside of the DC connector as negative and the outside of the connector as positive, is that weird?!


#57

Hi

I think the crimps are the issue with the switch as you have now proved the ATXRaspi works. Personally I’d remove the crimps and solder the connections.

As to the power for the screen you need to find out what the screen requires positive or negative to the centre. I think when you made the original connection it wasn’t right as in either one or both of the wires wasn’t making a good connection. Yes you should get a reading with the wires either way around.

Cheers

Paul


#58

Thanks again Paul,

So close now :)! Ok lesson learnt solder wire connections to button and power inlet, done with heat shrink photo to follow. Button now working :)! Last question power to the screen, does this picture of the LCD controller DC in help identify if it is ‘in pos’ ‘out neg’?


#59

Here’s the back:


#60

Hi

Unfortunately not did it come with any documentation?

If I had to guess I would say positive in the centre.

Cheers

Paul