How-to: Picade 12" Screen + HAT + Single Power Source + On/Off Buttons!


#61

Unfortunately not and I don’t think any useful info here:

http://vi.raptor.ebaydesc.com/ws/eBayISAPI.dll?ViewItemDescV4&item=151648143215&category=71509&pm=1&ds=0&t=1496512076350

I am at least getting a 12v reading from the cable now, here goes!!!..


#62

Unfortunately not :(, any useful info here:

http://vi.raptor.ebaydesc.com/ws/eBayISAPI.dll?ViewItemDescV4&item=151648143215&category=71509&pm=1&ds=0&t=1496512076350

I am at least getting a 12v reading from the cable now! Here goes!!..


#63

Unfortunatey not :(! I am at least getting a 12v reading from the cable now with pos in.

The link to the controller board is right at the top of the thread (jarrah’s original post), there is info in the item description but can’t see that it says the polarity of the dc in on the board? (Can’t post a link for some reason).

Well here goes!!..


#64

Hi

I took a look at that link and couldn’t find anything either.

My fingers are crossed.

Cheers

Paul


#65

Hey Guys!!

So good and bad news!! Pi and screen are booting up :))! Bad news is the screen picture is terrible!!! Shaking and line running across the screen :(! Will try to upload a photo, assuming this isn’t a dc polarity issue? Wondering if I have a bad screen or driver board :(! Does anyone have experience? Guess I’ll need to contact the sellers!

Firstly I want to thank you all so much for your help, particularly you Paul! Would have got this far without your help! Been a great learning curve, made some mistakes, picked up a few burns along the way! Have learnt a lot for the next project!

Any guidance on the bad picture would be great, hoping it’s a setting but suspect my screen and/or board are bad!

Cheers all!


#66

Hi

No problem and glad I could help.

If the polarity was wrong the screen wouldn’t work so my best guess is the driver board has a fault.

Cheers

Paul


#67

Cheers Paul,

So disappointing after getting it all working but I guess that’s how it goes sometimes learnt a lot for the next time!!

Will contact the board supplier, to see if I get a replacement.

Thanks again!


#68

Glad Paul was able to get you sorted.

Any update on the driver board replacement/re-flash?


#69

Hi Dyltone,

Cheers for the message, eBay seller has been really reassuring and responsive, another board on the way so fingers crossed that works!

So close! Lol! Really enjoyed this project though so will def be building more and hopefully learnt all my mistakes on the first :)!

Once screen is sorted want to change the artwork and joystick top/buttons :)! Any recommendations?

Cheers!


#70

If you power up the screen without the Pi connected via HDMI do you still see the distortion on the blue screen text?


#71

Hey Luis,

Thanks for the message, unfortunately the screen is still shakey and almost pixelated on the blue screen text even within any signal input.

Cheers!


#72

Hey guys!

So screen now working :)! A little backlight bleed on the panel but I can live with it, ended up finding a really good thread on 12" screens which led me to a new supplier of the controller board which works perfectly :)!

Next issue! Lol! I’m getting the yellow lightning bolt indicating there is an undervoltage problem particularly when the pi boots up and shuts down. I used the multimeter to test various points, when the system is on the voltage to the ATXraspi falls to 4.9v and then the com and pos GPIO pi pins are 4.7v or 4.8v so I’m losing power in the system. Any ideas? Could it be the step down converter? Or could it be the solder of the 12v in pos/neg wires?

Any thoughts welcome! Cheers!


#73

Hi

I had similar until I soldered all my connections but you are using a USB connector rather than the Molex kk connectors I used that shouldn’t be an issue.

I thought the under voltage was a small rainbow square in the top right of the screen. I don’t think I’ve seen a lightening symbol.

Does this only happen on boot and shutdown?

If you disconnect the Pi and ATXRaspi what voltage do you get out of the voltage converter?

Cheers

Paul


#74

Hey Paul,

Yeah apparently the lightning bolt symbol is the new under voltage (brown out) symbol. If I don’t overclock my pi I only get the symbol during boot up and shutdown. If I over lock the pi I get it continually.

It’s hard to measure the voltage purely coming out of the voltage converter as I have a micro USB connector, but if I look at the voltage hitting the ATXraspi without the pi being on, it’s a steady 5v. It’s only when the pi is turning on using the mom switch that the voltage hitting the ATXraspi drops to 4.9v. Then if I measure the voltage on the neg & 5v gpio pins on the pi itself it has dropped again to 4.7/4.8v. Wondering if the USB connecting the ATXraspi to the rpi is not good enough?

The solders to the DC in weren’t amazing, but they do deliver 5v to the ATXraspi under no load.

What do you think?

Cheers!


#75

Do micro USB cables have voltage or ampage ratings?


#76

Seen a few conversations around poor quality cables affecting voltage but I think they are more around the power plugs?


#77

Ok quick update :)! I tried resoldering the DC panel connector and seem to have made things worse lol! The lightning sign is now on all the time. ATXraspi 4.9v and the pi 4.7/4.8 definitely losing some power here, wondering if it is the converter. The first time I soldered the screen cable to one side and the converter cable to the other side of the Dc panel connector pins. This time I tried soldering both to the same place. One either side seems to work better, I do also have another step down converter from a different manufacturer that I will try, also have solder with more silver to see if that conducts better. Will try swapping all these bits out and let you know!

Cheers!


#78

Hi

Yes USB cables do have a current rating and it may be this one isn’t high enough. Are you able to solder the wires from the converter directly to the ATXRaspi? The connections are next to the USB socket where you can solder a DC power socket.

Which Pi do you have as I used a Pi 3 and only got the problem when the connections weren’t soldered.

Cheers

Paul


#79

Hi Paul,

Thanks for the message!! So done a little investigating, I plugged the step down converter directly into the pi and i don’t get the lightning bolt at all then. It seems that the issue is only when the ATXraspi is in the circuit, as soon as I plugged that back in then I continually get the lightning symbol.

Any ideas? I’ve tried about 3 different USB cables all with the same result.

Cheers!


#80

Oh so I forgot to say, yeah it’s a pi3 :)!