Motioneyesos suction camera holder


#41

You can ssh into motioneyesos, but it wants a password which I haven’t got yet. I logged in as admin on the web page, but no password, and that was it.
Edit, just tried a password I created in motioneyesos, but permission denied, please try again when trying to ssh into it.

On this page it seems a common issue, but someone thinks it’s a software issue:


My Pi Zero is not in any case, just free standing


#42

I have just finished copying from this to my PiZero

https://groups.google.com/forum/#!topic/motioneye/wxdFOn2a28M

Motioneye has now been installed onto raspian stretch, but the camera is still not showing. aaaagh!


#43

That looks like what I tried. Didn’t work for me. Motion Eye wouldn’t launch, no web interface to even see if the camera was detected. I could have made a typo or something though?


#44

I’ve bit the bullet and ordered a Pi3, so watch this space as they say.


#45

3B or 3B+, I’m guessing 3B+ but asking anyway? I have Motion eye running fine on two 3B’s. My 3B+ seems to have issues? Raspberry Pi Camera Issue
Every once in a while the stream stops for a couple of seconds, then starts again. That 3B+ currently has my oldest version 1 camera, the camera with the artifacts etc. I’ve been planning to swap it all back to its original setup but have just been too lazy or had other stuff on the go.
I started out with a Pi Zero and version 1 camera, it was what I had on hand. It worked Ok but lagged terribly.
So I then repurposed a Pi 3B I had hooked up to a AIY board. That worked so well I ordered a 3B+ and a new version 2 camera. Then the issues started. I’m still not 100% sure what is wrong. I’m leaning towards that 3B+ overheating. It was in a window in direct bright hot sunlight when it first stared failing.


#46

I’m sorry to say that I have now given up on the idea of using motioneyeos, and don’t want to be throwing good money after bad. As motioneyeos didn’t recognise either of my 2 cameras, and after googling this, I was not alone as many user were experiencing the same problem.
I already got 2 indoor rotate and tilt cameras which do work for what I want them for, as well as having 4 cctv outdoor cameras. Realisticly I don’t need any more.


#47

If I could find something as good I’d switch. My two 3B (not +) are working just fine 24/7. It’s just the 3B+ thats giving me problems. His forum is a bit of a pain. I got next to no support with issues I posted there. I suspect my 3B+ Motion Eye issues are with its WIFI. Not properly supported in Motion Eye. Just a hunch really. I can not get Motion Eye to work on 5Ghz, only works on 2.4Ghz. The 5 Ghz works just fine in Raspbian though.


#48

I’ve googled and googled this problem Ihave re the cameras, and it seems to come down to a driver problem for the camera.
The driver is called bcm2835, and has something to do with v41-utils as well.
Do you have the said driver etc on the Pi3 which is working for you.


#49

How do I check that, says the Linux NOOB.
EDIT: I’m soon going to pack it in for tonight. I may not get back to you until tomorrow some time. ;) .


#50

What mine shows is
Camera Device vc.ril.camera
Camera type MMAL Camera
Motion Eye Version 0.39.2
Motion version 4.1.1
OS Version - Motion Eye OS 20180627

EDIT: Thats a Pi 3B (not a +) with an official Pi Foundation version 2 camera attached to the CSI.


#51

Ok thanks for that.
Did you issue a command for the said information.

What does ls -la /dev/video show you. For me it reported ls: cannot access ‘/dev/video’ no such file or directory. I should have checked before I issued that said command because there is no /dev/video

As you said earlier, there is no proper support in the way of a motioneye forum.
The trouble is that what works for one does not alway work for someone else.


#52

The info I posted above I got via the Web GUI.
Under “Video Device” and “General settings”.
You may have to log in as admin and enable expert settings to see it.
I haven’t remoted into my Motion Eye setups via SSH etc, I’ve only ever used the web interface.
I can likely just take the SD card out and plug it into one of My Pi’s and have a look for that directory.


#53

I’m toying with replacing one or more of my 3B’s with 3A+'s. Assuming Motion Eye will run on them. That will let me do other things with the 3B’s. It will get me a smaller more compact setup.


#54

I found this on here:
https://hackaday.io/project/29174/instructions

When I get to this:
First you should do a firmware update of your raspberry to get the latest firmware and kernel driver - run the following in a terminal
sudo raspi-update
it returns:
sudo: raspi-update: command not found.

So that’s it, I can’t go any further and as it is on a webpage.

I sent a message to hackaday, and got an auto reply saing they would reply to my question within 7 days…ugh!

That’s what I mean, not proper support.


#55

In Raspbian its sudo apt-get update followed by sudo apt-get upgrade try that instead.

It looks like my issue is with Motion-Eye on my 3B**+** or I have a dud 3B+. I just put the 3B+ back in its original configuration with the V2 camera. I got several stream failures / breaks or pauses. I get a black screen with a camera with the do not enter circle bar thing on it. No Video. Then in a couple of seconds it comes back. That 3B+ has been doing it from day one. Even with a version 1 camera so its not the camera. Its the CSI interface, something else on the Pi, or the Motion Eye 3B+ combo? I don’t have another 3B+ to test with though?


#56

Thanks but the commnd you posted is further up that webpage, roughly after the 2nd paragraph, and I did do that before the next command re raspi-update.

It does seem touch and go with motioneye playing ball with a camera, and for me to much of a no no, to buy a RPi3 or later version.


#57

Try sudo rpi-update


#58

Great stuff thanks, it works

This update bumps to rpi-4.14.y linux tree
Be aware there could be compatibility issues with some drivers

The firmware now being updated


#59

4.14 is I believe the latest. As near as I can remeber anyway. I’m on my PC and don’t have a Pi booted up and running to go check.


#60

I think somebody may have got confused between raspi-config and rpi-update? Both are run at the command line.