Motioneyesos suction camera holder


#61

Now the next command runs without error:
sudo modprobe bcm2835-v4l2
If this worked without error messages, you should now have a device /dev/video0, check with ls - l /dev/vid*

Uh, uh, that did not work:
ls -l /dev/vid*
ls: cannot access ‘/dev/vid*’: No such file or directory

Which is true

I rebooted the Pi Zero, but still the same.

I need to add the bcm2385 to /etc/modules

I’m nearly there with this.


#62

Where your at is above my current skill level, to be honest. I do hope you sort it out. I really need to improve my Linux skills.


#63

Just an update here:
After sending hackaday 2 emails about the problem I am encountering, I have not yet had any response from them.
My last email was about 2 weeks ago. I’ll try once more then that’s it, game over as they say.


#64

You might want to see if you can contact the “author” of that Hack A Day Article. The person that submitted it. There may be a link to his site in there someplace.


#65

Good idea that, thanks, and I’ll do it.


#66

I contacted the authorand it turned out that the existing camera I had did not work, well, was not detected with this:
sudo vcgencmd get_camera
supported=1 detected=0

I bought a new camera from here and it is detected.

Now can I just ask you when you installed motioneye, did you install the motioneye image onto the sdcard or did you install it over raspian stretch to get it working.
Thanks


#67

I’m currently running the image flashed to a Micro SD Card. I tried to install it into Raspbian but could not get it to work.


#68

Thanks, that’s what I’ll do now. There’s too much work to do over the raspian stretch image.


#69

Oh, what size card did you use, and was it a class 10 card or just any.


#70

Lexar 300x 16gb HC I. I believe its a class 10.


#71

Thanks for that
I have motioneye working ok and the proper pi camera is showing images/pictures.


#72

Do you save any pictures to a server or just locally on the Pi3. I’m trying to get MotionEye to save pictures to my home server, but it complains about mounting the folder om my server.
It’s not important, but as the option is there in Motioneye, I’d like to use it.


#73

I’m just saving locally to the Pi.


#74

Further update:
I tried a couple tutorials? where motioneye was installed onto the raspian-stretch software after it was imaged onto a sdcard.
All was going well upto about 95 to 97 percent, without any errors.
The 1 off the hackaday site got as far as step 3,as after I ran the command from step 3 the camera was not recognised.

I then tried one from the author of motioneye, but again at about 97% my camera was detected, but not recognised by motioneye, even though I enabled it in raspian-config.
Just by chance after I read somewhere about the pi camera not working, but a USB one did, did I didg my old USB logitech camera out from the days of windows 98. It was recognised but the viewing angle was quite narrow, so that wasn’t really feasable.

So I am back to just motioneyeos on a 64Gb class 10 sdcard, and apart from not yet getting emails with pictures, it is working great with the wide angle camera.


#75

I went with Motion Eye mainly because I can view everything locally. I can do everything over my LAN. No having to stream to a web site on the Internet first. And go to that site to see my Video feeds or pictures.

I’m not using the motion detection at all, not yet anyway. I found it very tricky to setup and get working the way I want it to. I just use the one click button to take pictures. A similar button to start stop video would be nice.


#76

Aah, so you just look at the picture on a monitor webpage with the ip address of motioneye.
In my case it’s 192.168.0.27 on a web browser page, and then if I want to view the camera picture from anywhere else, I add 8081 onto the end of the ip address.

I found this useful for setting up motioneye:

Which is the 1 click button to take pictures?

Thanks


#77

For me, if I enter the ip address of one of my cameras I get the motion eye web interface.
Then I log in as admin, and enable advanced settings.
Then turn on Still Images and Enable Manual Snapshots. Then an icon / button appears in the lower right hand corner. Clicking that takes a snapshot / picture.


#78

I have mine setup a little different like you have, in as much that I have Capture Mode to Motion Triggered, and Preserve Pictures to For One Week.

The picture in mine is quite small when I have the settings menu open, but it will fill the whole screen otherwise. I am sitting more or less in front of the camera, to the side of me actually, and my cat is stting on the other side of me just now.
I see the 1 click take a snapshot button now. I only got it working yesterday evening, and I will be making some changes with the setup in a day or so.


#79

Move the Layout Columns in Preferences back to 1 and your view window will be bigger when in settings.
I went with 720P instead of 1080P, 1280 x 720 will give you more FPS in videos and smoother videos, IMHO.
I also set my Movie Quality at 75% to get a better less laggy / shuddery video.
If your only taking stills disregard the movie quality setting.
Changing the resolution will change the viewing angle a bit, or so it seemed to me.
I see you have the wide angle camera so I think I’d go with what ever they recommend for that.


#80

Thanks, that improves the size of the picture, I can see it now, lol.
Yes I also have 1280x720 resolution, and it does help. Movie quality is set at 75% is the default, and haven’t changed it here.
The wide angled camera is great for what it sees, an awful lot, virtually the whole room is visible more or less.

On the down side, I noticed that when changing certain settings and then Apply, the camera is not being picked up, so I have to do a reboot to get the camera back after logging in. I’m leaving it well alone now, until I find a better place for it.